The default bug view has changed. See this FAQ.

Lightning broken, tries to load libical backend although "calendar.icaljs" defaults to "true"

RESOLVED FIXED in 4.2

Status

Calendar
ICAL.js Integration
--
blocker
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Angelika, Assigned: Stefan Sitter)

Tracking

Lightning 4.2

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150511004005

Steps to reproduce:

I did the update from TB 39 to 40 and Lightning was automatically updated in this process.


Actual results:

No entries are displayed and the header of the entries flash.


Expected results:

Normal work.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Assignee)

Comment 1

2 years ago
Firefox developers decided that it is a good idea to drop support for binary XPCOM components in extensions. Therefore Lightning doesn't work anymore. Currently this affects Thunderbird 40 and newer too.

We tried to work around this by enabling the experimental icaljs library instead of libical library but it seems this doesn't work or there might be some more problems that need to be fixed to make icaljs work.

I switched my working profile from aurora to beta to get a working Lightning back. If you need your calendar I can only suggest to downgrade too until problems are solved.
(Assignee)

Comment 2

2 years ago
I think I found the problem, patch in preparation.
Assignee: nobody → ssitter
Status: UNCONFIRMED → ASSIGNED
Component: Lightning Only → ICAL.js Integration
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Compatibility with TB 40.0a2 → Lightning broken, tries to load libical backend although "calendar.icaljs" defaults to "true"
(Assignee)

Comment 3

2 years ago
Created attachment 8606252 [details] [diff] [review]
always check the preference

To workaround the problem that binary extensions are not supported anymore we temporary enabled icaljs by default with Bug 1162300. But Lightning still tries to load libical and fails. Reason is that the preference "calendar.icaljs" is only read when it is set by the user but not when it is set by default.
Attachment #8606252 - Flags: review?(philipp)
Attachment #8606252 - Flags: approval-calendar-aurora?(philipp)
Comment on attachment 8606252 [details] [diff] [review]
always check the preference

Review of attachment 8606252 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for bug hunting here! r=philipp
Attachment #8606252 - Flags: review?(philipp)
Attachment #8606252 - Flags: review+
Attachment #8606252 - Flags: approval-calendar-aurora?(philipp)
Attachment #8606252 - Flags: approval-calendar-aurora+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-central, comm-aurora]
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1165571

Comment 6

2 years ago
https://hg.mozilla.org/comm-central/rev/0a4fdc44efac
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed comm-central, comm-aurora] → [checkin-needed comm-aurora]
Target Milestone: --- → 4.1
(Assignee)

Updated

2 years ago
Target Milestone: 4.1 → 4.3
(Assignee)

Updated

2 years ago
Blocks: 1165726

Updated

2 years ago
Severity: normal → blocker
Backported to releases/comm-aurora changeset 10d35a0ece85
Keywords: checkin-needed
Target Milestone: 4.3 → 4.2
Whiteboard: [checkin-needed comm-aurora]
You need to log in before you can comment on or make changes to this bug.