Last Comment Bug 1165002 - Lightning broken, tries to load libical backend although "calendar.icaljs" defaults to "true"
: Lightning broken, tries to load libical backend although "calendar.icaljs" de...
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: ICAL.js Integration (show other bugs)
: Lightning 4.2
: All All
-- blocker (vote)
: 4.2
Assigned To: Stefan Sitter
:
:
Mentors:
: 1165571 (view as bug list)
Depends on:
Blocks: 1165726
  Show dependency treegraph
 
Reported: 2015-05-14 13:12 PDT by Angelika
Modified: 2015-05-19 06:02 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
always check the preference (1.31 KB, patch)
2015-05-15 05:00 PDT, Stefan Sitter
philipp: review+
philipp: approval‑calendar‑aurora+
Details | Diff | Splinter Review

Description User image Angelika 2015-05-14 13:12:52 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150511004005

Steps to reproduce:

I did the update from TB 39 to 40 and Lightning was automatically updated in this process.


Actual results:

No entries are displayed and the header of the entries flash.


Expected results:

Normal work.
Comment 1 User image Stefan Sitter 2015-05-14 13:20:21 PDT
Firefox developers decided that it is a good idea to drop support for binary XPCOM components in extensions. Therefore Lightning doesn't work anymore. Currently this affects Thunderbird 40 and newer too.

We tried to work around this by enabling the experimental icaljs library instead of libical library but it seems this doesn't work or there might be some more problems that need to be fixed to make icaljs work.

I switched my working profile from aurora to beta to get a working Lightning back. If you need your calendar I can only suggest to downgrade too until problems are solved.
Comment 2 User image Stefan Sitter 2015-05-15 04:49:11 PDT
I think I found the problem, patch in preparation.
Comment 3 User image Stefan Sitter 2015-05-15 05:00:22 PDT
Created attachment 8606252 [details] [diff] [review]
always check the preference

To workaround the problem that binary extensions are not supported anymore we temporary enabled icaljs by default with Bug 1162300. But Lightning still tries to load libical and fails. Reason is that the preference "calendar.icaljs" is only read when it is set by the user but not when it is set by default.
Comment 4 User image Philipp Kewisch [:Fallen] 2015-05-15 11:36:52 PDT
Comment on attachment 8606252 [details] [diff] [review]
always check the preference

Review of attachment 8606252 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for bug hunting here! r=philipp
Comment 5 User image Stefan Sitter 2015-05-16 06:49:52 PDT
*** Bug 1165571 has been marked as a duplicate of this bug. ***
Comment 7 User image Philipp Kewisch [:Fallen] 2015-05-19 06:02:12 PDT
Backported to releases/comm-aurora changeset 10d35a0ece85

Note You need to log in before you can comment on or make changes to this bug.