[RTL][Message]The VFC file name is cut off in SMS.

RESOLVED DUPLICATE of bug 883884

Status

Firefox OS
Gaia::SMS
P3
normal
RESOLVED DUPLICATE of bug 883884
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l][sms-papercuts])

Attachments

(1 attachment)

Comment hidden (obsolete)
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
[1.Description]:
[RTL][Flame2.2&3.0][Nexus5 2.2&3.0][Message]Add a contact as attachments in message and send out this SMS, you can see the VFC file name is cut off.

See attachment:VFC file name.png

[2.Testing Steps]: 
Precondition:There are some contacts with a long name saved. Change system language to Arabic.
1.Launch message.
2.Tap new message button.
3.Tap attachment button and select communications.
4.Select one contact.
5.Add recipient.
6.Send this SMS.

[3.Expected Result]: 
6.While the file name is too long, it should be ended with ellipsis.

[4.Actual Result]: 
6.You can see the VFC file name is cut off.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.040500
Firmware Date          Thu May 14 04:05:11 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150514131323
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/633684c4ebc4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.165247
Firmware Date          Thu May 14 16:53:00 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150514.033743
Firmware Date          Thu May 14 03:37:59 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150514010203
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fab94ad196c
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150514.044222
Firmware Date          Thu May 14 04:42:38 EDT 2015
Bootloader             HHZ12f


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
P3, polish
Keywords: polish
Priority: -- → P3
Since -moz-plaintext didn't treat the ellipsis well and for the file name case it seems not necessary to use -moz-plaintext, it would be easier if we replace it with dir="auto".
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][sms-papercuts]
This should also be resolved by bug 883884. So if it's not a blocker we might as well dupe to that one?
See Also: → bug 883884
Since it's not 2.2 blocker for now, sounds reasonable to set dupe to gecko issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883884
You need to log in before you can comment on or make changes to this bug.