Closed Bug 1165189 Opened 6 years ago Closed 6 years ago

Flash Player17.0.0.188 and later hangs when entering fullscreen on Firefox39.0 and earlier

Categories

(Core :: Plug-ins, defect)

31 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 1133351

People

(Reporter: alice0775, Unassigned)

Details

On windows7 x64, Flash Player hangs when entering fullscreen on Firefox31ESR

Affected version :
Flash Player 17.0.0.188 and 18beta are affected.
Flash Player 13.0.0.289 and 17.0.0.169 are not affected.

Steps to Reproduce:
1. Install Firefox31.0.7ESR
https://download.mozilla.org/?product=firefox-31.7.0esr-SSL&os=win&lang=en-US
2. Install Flash Player 17.0.0.188
3. Start Firefox
4. Open CNN video or Youtube video etc and Play
5. Click Fullscreen Icon in the video controls

Actual Result:
Flash Player stops response.

Expected Result:
Flash Player should play back the video in Fullscreen

Any Workarounds:
Toggle to normal mode and then toggle to fullscreen mode again.
OR
Install old version of Flash Player.
I have also filed a adobe bug as follows:
https://bugbase.adobe.com/index.cfm?event=bug&id=3988493
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
http://edition.cnn.com/videos/ is affected on 38.0.5b1
Summary: Flash Player17.0.0.188 and later hangs when entering fullscreen on Firefox31ESR → Flash Player17.0.0.188 and later hangs when entering fullscreen on Firefox39.0 and earlier
STR:
1. install Flash Player 17.0.0.188 or 18beta
2. Open edition.cnn.com/videos
   e.g. http://edition.cnn.com/videos/us/2015/05/13/inside-supermax-prison-orig.cnn/video/playlists/trending-video/
3. Click Fullscreen Icon in the video controls

Actual Result:
Flash Player stops response.

Fixed range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4156586d7ac6&tochange=829195e67537

Fixed by: Bug 1133351
Depends on: 1133351
Flags: needinfo?(aklotz)
[Tracking Requested - why for this release]: Flash player hangs on major web page
Component: Flash (Adobe) → Plug-ins
Product: Plugins → Core
Version: unspecified → 31 Branch
[Tracking Requested - why for this release]:
Disabling protect mode of Flash Plagin helps.
We cannot uplift bug 1133351 without fixing bug 1151318 first. I'm probably going to add a quirks flag to handle the latter.
Depends on: 1151318
Flags: needinfo?(aklotz)
[Tracking Requested - why for this release]:
Too late for the 38 cycle.

We probably want to track it for 39.
Tracking enabled for 39, 40, & esr38+ (not sure how to or if I should track firefox-esr31), to ensure the affected releases are fixed.
18.0.0.160 does NOT fix the problem :(
(In reply to Alice0775 White from comment #10)
> 18.0.0.160 does NOT fix the problem :(

I'd been seeing the same behavior on 17.0.0.188. Tried 18.0.0.162 and couldn't repro using SM 2.33.1 or FF 39.0b3. Can someone else confirm?
Tested with Flash 18.0.0.160 and 18.0.0.162beta:
Firefox39.0b3(Bug 1133351 had landed) fixes the problem.
However, I can still reproduce on Firefox38.0ESR and 31.0.6ESR
(In reply to Alice0775 White from comment #12)
> Tested with Flash 18.0.0.160 and 18.0.0.162beta:
> Firefox39.0b3(Bug 1133351 had landed) fixes the problem.
> However, I can still reproduce on Firefox38.0ESR and 31.0.6ESR

Today being Patch Tuesday, Adobe also is likely to release 18.x.x.
I'm going to mark this as a dupe. bug 1133351 is the fix for this problem. We can consider uplifting that to ESR38.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1133351
Jen, can you please fix up the tracking flags as necessary in light of my duping? I probably wouldn't do it properly. ;-)
Flags: needinfo?(inkpixelspaper)
Tracking removed, and I see tracking for 39 on bug 1133351 which is fixed.
Flags: needinfo?(inkpixelspaper)
Flash player 18.0.0.194 still hangs up
Alice, using what version of Firefox?
Flags: needinfo?(alice0775)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #18)
> Alice, using what version of Firefox?

ESR38.0.1
https://hg.mozilla.org/releases/mozilla-esr38/rev/d0fb637e6902
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150514102509
Flags: needinfo?(alice0775)
This bug is duped to 1133351 which only landed for 39. Can you retry with FF39 beta/RC?
I cannot reproduce the problem on Firefox39.0b7. (See also Comment#12)

https://hg.mozilla.org/releases/mozilla-beta/rev/900c78b9be48
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150618135210
Great, thanks!
Status: RESOLVED → VERIFIED
[Tracking Requested - why for this release]:
I can reproduce the Plugin hang on ESR38.1
https://hg.mozilla.org/releases/mozilla-esr38/rev/61f7702f2ddc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150624141534

And I can verify that I cannot reproduce the hang on ESR38.2 anymore.
https://hg.mozilla.org/releases/mozilla-esr38/rev/eff70db14dbe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150803192212
You need to log in before you can comment on or make changes to this bug.