[FxA] The long email address will be cut off in "Confirm Your Account" view.

VERIFIED FIXED in 2.2 S14 (12june)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: ferjm)

Tracking

({regression})

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(9 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flamev2.2][Settings]Create firefox account in Settings, the long email address will be cut off in "Confirm Your Account" view.
See attachments:
Arabic_long email address.png
Basque_long email address.png
Bengali India_long email address.png
Greek_long email address.png
Russian_long email address.png

[2.Testing Steps]: 
1.Set your phone language to Russian, Bengali India, Greek, Basque, Arabic and connect to network.
2.Launch Settings and select "Firefox Accounts".
3.Tap "Create account or sign in" and input a long email address that has not been registered for the firefox account.
4.Tap "Next" button and select "2001 or earlier" under "Age Verification".
5.Tap "Next" button  and input the password.
6.Tap "Next" button and tap "Done" button to enter the "Confirm You Account" view.

[3.Expected Result]: 
6.The long email address should not be cut off and the ellipsis should be shown.

[4.Actual Result]: 
6.The long email address will be cut off.

[5.Reproduction build]: 
Device: Flame 2.1 user build (Unaffected)
Build ID               20150514001201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/23eb9df75991
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.035617
Firmware Date          Thu May 14 03:56:27 EDT 2015
Bootloader             L1TC000118D0


Device: Flame 2.2 user build (Affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.040432
Firmware Date          Thu May 14 04:04:43 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
This issue dose not exist in Spanish, Serbian Cyrillic, Polish, Portuguese Brazil, Portuguese Portugal.
Regression -- blocking 2.2
blocking-b2g: --- → 2.2+
Keywords: regression
I'm actually not sure if we can consider this as a regression in this case (truncated before, runs off screen now). But I'm concerned we don't see the email there, as that leaves out important information to the user and creates confusion

Updated

4 years ago
Component: Gaia::Settings → FxA
Summary: [Settings]The long email address will be cut off in "Confirm Your Account" view. → [FxA] The long email address will be cut off in "Confirm Your Account" view.
Hi Lancy,
Is this also able to reproduce on master?
Flags: needinfo?(yulan.zhu)

Comment 9

4 years ago
Triage 2.2+

Hi Ryan, are you in charge of Firefox Account engineering related? Please help to have a look, or lead this bug to right person. Thanks!
Flags: needinfo?(rfkelly)
(Reporter)

Comment 10

4 years ago
(In reply to Josh Cheng [:josh] from comment #8)
> Hi Lancy,
> Is this also able to reproduce on master?

Hi Josh,

According to the STR in comment 0, this issue can be reproduced on latest flame 3.0 user build in Russian, Bengali India, Greek, Basque and Arabic languages.
See attachment:Verify1_long email address_v3.0_affected.png
Reproducing rate:10/10

Flame 3.0 user build: (Affected)
Build ID               20150519160202
Gaia Revision          97dc139f1a690224e98533a86526c4165eed1db5
Gaia Date              2015-05-19 04:43:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4fb7ff694bf5
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.193049
Firmware Date          Tue May 19 19:31:00 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(yulan.zhu) → needinfo?(jocheng)
Sadly I don't have a lot of context on what's happening with FxA in B2G or who is maintaining that code.  IIRC Jared did some work with it in the past, so ni? him for further triage.
Flags: needinfo?(rfkelly) → needinfo?(6a68)

Updated

4 years ago
Flags: needinfo?(jocheng)
Hi Jared,
Just a soft reminder, we are approaching CC at June 8th. 
Could you help to comment? Thank you!
Hi all,

Sorry, I was on PTO last week, but forgot to update my Bugzilla profile.

It's impossible to tell from the FxA component name, but the FxA code is actually part of the System app. One of the System app owners/peers[1] could tell you who is a good, active reviewer for that code.

I haven't worked on FxOS since November 2014. At that time, :ferjm was the reviewer for FxA changes inside the System app...but I don't know if he is still working on FxOS or that code.

So, summing up: ping a System owner or peer in your timezone and hopefully that person will know :-)

Good luck!

Jared

[1] https://wiki.mozilla.org/Modules/FirefoxOS#System
Flags: needinfo?(6a68) → needinfo?(awu)

Comment 15

4 years ago
Thanks Jared!

I know Fernando is still working for FxOS, let me ni? ferjm and see if we can make it done.
Flags: needinfo?(awu) → needinfo?(ferjmoreno)
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
(Assignee)

Updated

4 years ago
Attachment #8613305 - Flags: review?(arthur.chen)
(Assignee)

Updated

4 years ago
Component: FxA → Gaia::Settings
Comment on attachment 8613305 [details] [review]
[gaia] ferjm:bug1165248.fxa.confirmemail > mozilla-b2g:master

EJ, could you help review the patch? Thanks.
Attachment #8613305 - Flags: review?(arthur.chen) → review?(ejchen)
Comment on attachment 8613305 [details] [review]
[gaia] ferjm:bug1165248.fxa.confirmemail > mozilla-b2g:master

Thanks Fernando, r+
Attachment #8613305 - Flags: review?(ejchen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#yKvsKCXjRaCzvB1JEnvJzA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F → LocRun2.2
(Reporter)

Comment 21

4 years ago
According to the STR in comment 0, this issue is verified pass on latest flame 3.0 user build, the long email address is displayed with ellipsis in "Confirm Your Account" view in Russian, Bengali India, Greek, Basque and Arabic languages.
See attachment:Verify2_long email address_v3.0_Pass.png.
Reproducing rate:0/10

Flame 3.0 user build (Pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.192923
Firmware Date          Wed Jun  3 19:29:35 EDT 2015
Bootloader             L1TC000118D0
Please request Gaia v2.2 approval on this when you get a chance.
Flags: needinfo?(ferjmoreno)
Target Milestone: --- → 2.2 S14 (12june)
Comment on attachment 8613305 [details] [review]
[gaia] ferjm:bug1165248.fxa.confirmemail > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Firefox Accounts
[User impact] if declined: Bad UX
[Testing completed]: QA verified
[Risk to taking this patch] (and alternatives if risky): Very low. CSS change only
[String changes made]: None
Flags: needinfo?(ferjmoreno)
Attachment #8613305 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8613305 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
Comment hidden (obsolete)
(Reporter)

Comment 26

4 years ago
According to the STR in comment 0, this issue is verified pass on latest flame v2.2 user build, the long email address is displayed with ellipsis in "Confirm Your Account" view in Russian, Bengali India, Greek, Basque and Arabic languages.

See attachment:Verify3_long email address_v2.2_Pass.png.
Reproducing rate:0/10

Device: Flame 2.2 user build (Pass)
Build ID               20150614162504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.200131
Firmware Date          Sun Jun 14 20:01:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
(Reporter)

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.