"Save Link As..." downloads files without their correct extension.

VERIFIED DUPLICATE of bug 115176

Status

Core Graveyard
File Handling
--
major
VERIFIED DUPLICATE of bug 115176
16 years ago
2 years ago

People

(Reporter: Dvir, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On 0.9.7, the "Save Link As..." functionality was changed, so the name of the
saved file is taken from the text displayed on the link. Before, it took the name
of the actual downloaded file (which is how it works in IE & Netscape 4). While
the usefulness of this functionality is arguable, it is definitely problematic
right now.

for example:
while working with windows 98, go to http://www.mozilla.org/releases/ and
right-click on "talkback enabled Full Installer" under "MacOS 8.5 - 9.x". Select
"Save Link As", and the Save File dialog is opened. Note that the displayed file
name has a ".exe" extension (which is suitable for windows executables, but not
correct with mac binaries). The original extension for the file was ".bin", and
it should be maintained.

Try other examples on this page and you'll see that sometimes the extension is
correct, sometimes it isn't, and sometimes it's missing entirely.
apart from that, this functionality seems problematic. for example, many pages
which have links to pictures have text which is identical for all pictures,
while the actual file name differs. If someone wants to save many links from a
page like that he has to manually change the name of each downloaded file.

Since the change was made, It also takes the "Save As" dialog a long time to be
displayed (something like 5 seconds on my computer, but it varies between links).
very nice bug report !

This looks like bug 115176
Please reopen if you disagree !


*** This bug has been marked as a duplicate of 115176 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.