YouTube videos do not play in an e10s window with H.264 enabled and webm disabled.

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Zaggy1024, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(e10s-, firefox44 verified)

Details

(Whiteboard: Needs more reliable STR)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150515030202

Steps to reproduce:

1. Start up Firefox Nightly with E10S enabled.
2. In about:config set "media.mediasource" and "media.mediasource.mp4" enabled and "media.mediasource.webm" disabled.
3. Open a YouTube video (example: https://www.youtube.com/watch?v=H0tsvRctTY4) and attempt to play it.


Actual results:

The video does not play (buffering icon shows indefinitely with a black background). Looking at the debug information, it seems as though the video began to buffer, but then stopped after about a second or so. (screenshot of debug information: http://i.imgur.com/Y5v8Ie2.png)
Pausing and playing does nothing, and when attempting to seek, the UI becomes stuck showing the thumbnails of the video.


Expected results:

The video should buffer successfully and begin to play.
Reporter

Comment 1

4 years ago
In an e10s window, the video loads and begins playing nearly instantly. As far as I can tell (from my very limited perspective), this seems to be an issue with e10s.
Reporter

Comment 2

4 years ago
I can't check whether this occurs in safe mode because it disables e10s (without changing the checkbox state in the options page), and it can't be re-enabled without restarting the browser.
Comment 1 says that you're able to get the video playing in an e10s window. Is that a typo?
Flags: needinfo?(Zaggy1024)
Reporter

Comment 4

4 years ago
Oh, yeah. Sorry, I meant to say that it works in a non-e10s window.
Flags: needinfo?(Zaggy1024)
Tracy - are you able to reproduce this?
Flags: needinfo?(twalker)

Comment 6

4 years ago
I've had the same problem - enabling webm as a media source in about:config fixes the problem and I can watch videos on YouTube. Looking at the Network tab of the developer tools, it looks like YouTube buffers the video by loading both mp4 and webm files, which is why it doesn't work otherwise.
I am unable to reproduce. my browser is default set to those settings in STR #2.  Have no trouble with youtube videos in general and no problem with the one specifically suggested in STR #3.
Flags: needinfo?(twalker)
Ill try with Windows.
Flags: needinfo?(twalker)
I cannot reproduce on Windows SurfacePro either.
Flags: needinfo?(twalker)
minus until we get good str.
tracking-e10s: --- → -
Whiteboard: Needs more reliable STR

Comment 11

4 years ago
Video doesn't play but progress bar keeps progressing and audio keeps playing.

Windows 7. 64 bit. Firefox Aurora 41.

[Testday-20150731]
the video loads and begins playing , in wondow 8.1
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Zaggy1024 or Moin, can you still reproduce this YouTube problem in Firefox 43?

Comment 14

3 years ago
@Chris Peterson(In reply to Chris Peterson [:cpeterson] from comment #13)
> Zaggy1024 or Moin, can you still reproduce this YouTube problem in Firefox
> 43?

I just tested in my available version Firefox 44.0b8, it works fine. Plays video and audio as expected.
Thanks for testing, Moin!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.