Closed Bug 1166171 Opened 5 years ago Closed 5 years ago

NS_MOUSE_MOZLONGTAP event does not send to content process

Categories

(Core :: Panning and Zooming, defect)

Unspecified
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
b2g-master --- affected

People

(Reporter: TYLin, Unassigned)

References

Details

Reproduce Steps:
1. Open Messages app on B2G
2. Create a new message, and type arbitrary text into the message body
3. Long press to select a word in the message body.

Actual results:
The word under the finger does not being selected.

Expected results:
A word under the finger being selected.

Some analysis:
From the SelectionCarets log, the NS_MOUSE_MOZLONGTAP is handled by process 8737, which is the b2g process instead of the message app process.

I/PRLog   ( 8737): -1224937132[b6b4e080]: SelectionCarets (acd0c3d0): HandleEvent:275 : SelectWord from NS_MOUSE_MOZLONGTAP
I/PRLog   ( 8737): -1224937132[b6b4e080]: SelectionCarets (acd0c3d0): SelectWord:586 :  frame a91a9b48 is not selectable
I/PRLog   ( 8737): -1224937132[b6b4e080]: SelectionCarets (acd0c3d0): HandleEvent:281 : SelectWord from NS_MOUSE_MOZLONGTAP failed!

APPLICATION    SEC USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              0 root      8737  1     253092 90188 ffffffff b6f1f894 S /system/b2g/b2g
(Nuwa)           0 root      8755  8737  101748 24212 ffffffff b6f1f894 S /system/b2g/b2g
Homescreen       2 u0_a9019  9019  8737  132052 44772 ffffffff b6eea894 S /system/b2g/plugin-container
Built-in Keyboa  2 u0_a9081  9081  8737  118228 41752 ffffffff b6f41894 S /system/b2g/plugin-container
Browser          2 u0_a9311  9311  8755  124452 34140 ffffffff b6f1f894 S /system/b2g/b2g
Messages         2 u0_a9410  9410  8737  119400 42888 ffffffff b6f3a894 S /system/b2g/plugin-container
UI tests         2 u0_a9432  9432  8755  120280 27776 ffffffff b6f1f894 S /system/b2g/b2g
(Preallocated a  2 u0_a9573  9573  8755  110700 19288 ffffffff b6f1f894 S /system/b2g/b2g
No longer blocks: 1166191
qawanted for branch checks and a regression window if this is a regression.
Flags: needinfo?(npark)
Keywords: qawanted
OS: Unspecified → Gonk (Firefox OS)
I cannot reliably reproduce this bug following the STR. However this bug reminds me of bug 1166193, and I can only start to reproduce this bug after bug 1166193 has occurred.

Traits in common for this bug, bug 1166191, and bug 1166193: Memory specific (512MB; won't happen on 319MB, which all testers are on), touch events won't register on upper half of screen while keyboard is invoked.

Bug 1166193 seems to be reproducing more reliably, and it is no longer happening on latest.

Bug reporters please test on latest to see if it's still reproducible.
As can be seen from bug 1166191 comment 5, I also tested this bug on latest pvt. I can't reproduce this bug either.
Thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(npark)
Resolution: --- → WORKSFORME
Thank you.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.