[B2G] GetCellInfoList cannot work

RESOLVED FIXED in Firefox 41

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: alchen, Assigned: edgar)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When using "GetCellInfoList" in gecko, the callback does not being called.
Hi Alphan, I remember testing it locally... may I know how you are using it? or do you have a patch so that I can test it? Thanks.
Comment hidden (obsolete)
(Assignee)

Comment 3

3 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #2)
> It is a regression of bug 1113054, the response handler of
> REQUEST_GET_CELL_INFO_LIST is overwritten to |null| [1]. :(
> 
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1113054
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
https://hg.mozilla.org/mozilla-central/annotate/e94dc650c901/dom/system/gonk/ril_worker.js#l5647
(Assignee)

Updated

3 years ago
Assignee: nobody → echen
(In reply to Edgar Chen [:edgar][:echen] from comment #3)
> (In reply to Edgar Chen [:edgar][:echen] from comment #2)
> > It is a regression of bug 1113054, the response handler of
> > REQUEST_GET_CELL_INFO_LIST is overwritten to |null| [1]. :(
> > 
> > [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1113054
>       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> https://hg.mozilla.org/mozilla-central/annotate/e94dc650c901/dom/system/gonk/
> ril_worker.js#l5647

Oh I see, thanks for the update. :)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
Blocks: 1154435
(Reporter)

Updated

3 years ago
No longer blocks: 1154435
(Reporter)

Updated

3 years ago
Blocks: 1168064
(Assignee)

Comment 5

3 years ago
Created attachment 8610494 [details] [diff] [review]
Patch, v1

Fix and add marionette test for it.
(Assignee)

Comment 6

3 years ago
Comment on attachment 8610494 [details] [diff] [review]
Patch, v1

Review of attachment 8610494 [details] [diff] [review]:
-----------------------------------------------------------------

In this patch, I add a test for getCellInfoList().
But RIL_REQUEST_GET_CELL_INFO_LIST is introduced since ril version 8 [1], emulator-ics (ril version 7) doesn't support it. We have to skip it when in emualtor-ics.
I have tried adding `skip-if = android_version == "15"` in manifest, but it doesn't work. :(
I guess marionette test doesn't support `android_version` and we probably need to do the same thing as in mochitest [2] and xpcshell [3] to make it work? (I am not sure).
Before figuring out how to make marionette test support `android_version`, I just check `ro.build.version.sdk` system property in test script.

Hi Hsinyi, would you mind reviewing this? Thank you.

[1] https://github.com/mozilla-b2g/platform_hardware_ril/commit/8a9e02161271505de274db0c3a88087056dd5dfc
[2] https://dxr.mozilla.org/mozilla-central/source/testing/mochitest/runtestsremote.py#503
[3] https://dxr.mozilla.org/mozilla-central/source/testing/xpcshell/remotexpcshelltests.py#218
Attachment #8610494 - Flags: review?(htsai)
Comment on attachment 8610494 [details] [diff] [review]
Patch, v1

Review of attachment 8610494 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch!!!
Attachment #8610494 - Flags: review?(htsai) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fc7990f05afa
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S13 (29may)
You need to log in before you can comment on or make changes to this bug.