Closed Bug 1166175 Opened 4 years ago Closed 4 years ago

BlueZ leaks instances of |BluetoothSocket|

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1058371

People

(Reporter: tzimmermann, Unassigned)

References

Details

Attachments

(2 files)

Bluetooth's BlueZ backend leaks 5 instances of |BluetoothSocket| during Mochitests. It's unknown if this is from incomplete cleanup or happens on each transfer.

Attached is a log from the try server. Search for 'leakcheck.'
See Also: → 1161020
Some of the early BT errors are (apparently) not present on a real device; flame in this case.
Failed initialization leaks some of the managers. Let's see if this helps.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=001ef05de8ac
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #4)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=55b58f306871

Worked. Let's see if it fails without the BT fixes.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a4d23ed206d9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058371
You need to log in before you can comment on or make changes to this bug.