If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Toolkit
Telemetry
RESOLVED DUPLICATE of bug 1188888
2 years ago
5 months ago

People

(Reporter: sfink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
It would be very convenient to be able to register enumeration names. For example, we have a GC_REASON_2 histogram that can be any one of a couple of dozen different values, and mapping the numeric value to what it means is a nuisance (and error-prone.)

It would be nice if we could list out the mapping between reasons and their string descriptions, and have that show up in both about:telemetry and the dashboard and wherever else this stuff is reported.

(My browser usually GCs because 47, but quite a few are because 48 and a nontrivial number are because 36 and 52.)
We now have categorical histograms, which allow to do that:
http://gecko.readthedocs.io/en/latest/toolkit/components/telemetry/telemetry/collection/histograms.html#categorical
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188888
You need to log in before you can comment on or make changes to this bug.