Closed Bug 1166372 Opened 5 years ago Closed 5 years ago

Don't reopen tabs after crash

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: st3fan, Assigned: sleroux)

References

Details

(Whiteboard: noteworthy)

Attachments

(1 file)

There are techniques to find out if the app last exited because of a crash. In that case we can ask the user if the tabs should be restored or not. Or choose to not restore tabs.

This prevents a 'crash loop' when you have a bad URL in your open tabs that immediately crashes the app when loaded during startup.
UI not needed for v1. But stopping the crash loop would be nice.
tracking-fennec: ? → +
Assignee: nobody → sarentz
The state restoration framework should be preventing crash loops an invalid state restoration causes, by deleting the restore file if a crash occurs during restoration.

Noted: 'should' and 'does' are not the same.
Let's morph this down to the simplest possible thing: detect a crash and don't restore. We can present the option to restore in a later bug.
Status: NEW → ASSIGNED
Summary: We need to recognize when we crashed and then allow the user to not reopen tabs → Don't reopen tabs after crash
Assignee: sarentz → nobody
Status: ASSIGNED → NEW
Assignee: nobody → sleroux
I have some code that we can use to detect when we've previously crashed and will put up a patch after https://bugzilla.mozilla.org/show_bug.cgi?id=1159754 gets merged down as it changes the way we restore tabs.
Depends on: 1159754
Hey Matej, 

We were thinking of showing the user a prompt asking if they want to restore their tabs after crashing or not instead of blindly getting rid of them. Do you know if we have existing copy on Desktop/Android for this that we could use?
tracking-fennec: + → ---
Flags: needinfo?(matej)
(In reply to Stephan Leroux [:sleroux] from comment #5)
> Hey Matej, 
> 
> We were thinking of showing the user a prompt asking if they want to restore
> their tabs after crashing or not instead of blindly getting rid of them. Do
> you know if we have existing copy on Desktop/Android for this that we could
> use?

Unfortunately I'm not the right person to ask about existing in-product strings and I'm not sure who better to point you to.

I know we have this copy on desktop (from about:sessionrestore), in case it helps:


Well, this is embarrassing.

Firefox is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page.

You can try:

    Removing one or more tabs that you think may be causing the problem
    Starting an entirely new browsing session
Flags: needinfo?(matej)
Note: This includes additional strings if we want to do with the prompt route.
Attachment #8630606 - Flags: review?(sarentz)
:st3fan I only assigned this review to you since we were talking about it but feel free to pass it along to someone else.
Comment on attachment 8630606 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/654

Looks good. Lets land it so that we can get feedback from testers asap.
Attachment #8630606 - Flags: review?(sarentz) → review+
Thanks! Merged.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: noteworthy
You need to log in before you can comment on or make changes to this bug.