"Image Search Options" add-on does not work with e10s

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: AsukaLangleyfag, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
https://addons.mozilla.org/en-US/firefox/addon/image-search-options/
I already contacted with author (xamayon@gmail.com) and he said:
>If there's no easy workaround it may be a while before I can can do a
proper fix. Very troubling...
tracking-e10s: --- → +

Comment 1

3 years ago
Created attachment 8701256 [details] [diff] [review]
imagesearchoptions.patch

With the changes in the attached patch image search options works in the current firefox developer edition with e10s enabled.

Comment 2

3 years ago
Created attachment 8701278 [details] [diff] [review]
imagesearchoptions2.patch

Same as v1 but avoids an unnecessary double conversion and therefore works on large images properly as well.

Also, I forgot to mention the {relatedToCurrent: true} change is not strictly necessary, but it makes the extension behave like open link in new tab and similar menu items which is the correct thing to do.
Attachment #8701256 - Attachment is obsolete: true

Comment 3

3 years ago
Nice job Andreas! Have you contacted the original developer yet?

Comment 4

3 years ago
Thanks Andreas! Just applied the patch and submitted for review a few minutes ago. Hopefully all goes well and it gets released soon.
I have the Image Search Options addon installed from AMO that claims it was released on 2016/03/04, does that mean I have this fix now?  arewee10syet.com says it's still not compatible, but points at this bug.  Does the bug need to be resolved?  (I can't test because I have e10s disabled because of too many addons still marked incompatible)
(Reporter)

Comment 6

2 years ago
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #5)
> I have the Image Search Options addon installed from AMO that claims it was
> released on 2016/03/04, does that mean I have this fix now? 
> arewee10syet.com says it's still not compatible, but points at this bug. 
> Does the bug need to be resolved?  (I can't test because I have e10s
> disabled because of too many addons still marked incompatible)

Author fixed it, now it works with e10s, can confirm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.