Rename "Marketplace" link on about:home

VERIFIED FIXED in Firefox 41

Status

()

Firefox
General
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: namir@mozilla.com, Assigned: Baptiste Emmanuel, Mentored)

Tracking

unspecified
Firefox 41
Points:
---

Firefox Tracking Flags

(firefox41 verified)

Details

(Whiteboard: [Bugday-20150701])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Rename "Marketplace" link on new tab page. Change to "Apps" so it's consistent with Tools and Hamburger menus.

Thanks
(Assignee)

Comment 1

3 years ago
Hi,

I would like to work on this bug.
(Assignee)

Comment 2

3 years ago
Created attachment 8608562 [details] [diff] [review]
replace_marketplace_label.patch.v1
Attachment #8608562 - Flags: review?(adw)
namir@mozilla.com, I think you meant about:home, not the new tab page, which means about:newtab?  There's no Marketplace link on about:newtab but there is on about:home.
Component: New Tab Page → General
Comment on attachment 8608562 [details] [diff] [review]
replace_marketplace_label.patch.v1

Review of attachment 8608562 [details] [diff] [review]:
-----------------------------------------------------------------

Baptiste, thanks for the patch, but this bug is assigned to Chad, and there may be context here that we're not aware of, so unless he knows that you're working on it, we should let him take care of it.  And for future reference, any time you update an l10n string, you have to rename its entity, so for example, we would need to rename this abouthome.appsButton2.label.
Attachment #8608562 - Flags: review?(adw)
Status: NEW → ASSIGNED
(Assignee)

Comment 5

3 years ago
Ok, thank you for the advice.
(Reporter)

Comment 6

3 years ago
Yes, I meant the new window page.
And there is no additional context from my end , I assigned to Chad as he 1) has been point of contact for approving this link being added to the page and 2) OK'd the change request.

Thanks
(Assignee)

Comment 7

3 years ago
Do you mean that I can be assigned to this bug ?
Flags: needinfo?(namir)
Flags: needinfo?(adw)

Comment 8

3 years ago
Drew--thanks for the advice and counsel here.  Feel free to re-assign this to Baptiste if that makes sense.
Cool, thanks for the update.  Baptiste, feel free to work on this.
Assignee: cweiner → baptiste.em
Flags: needinfo?(namir)
Flags: needinfo?(adw)
(Assignee)

Comment 10

3 years ago
Just a question, why we have to rename the entity if we change the string ? And if I rename the entity I will also have to change all the references in the code ?
Flags: needinfo?(adw)
(Assignee)

Comment 11

3 years ago
Could it be possible to have more information ?
Baptiste, this page talks about it: https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Changing_existing_strings

To be honest though we pretty much always rename the property/entity, regardless of whether the "changes are relevant only for English."  To err on the safe side and make sure it's properly localized, I guess.

So yes, that means you need to update all references in the code.  Fortunately there's only one: http://mxr.mozilla.org/mozilla-central/search?string=abouthome.appsButton.label

In this case "appsButton" already describes the entity well since we're changing it to be "Apps", so I think we should call it abouthome.appsButton2.label.  When we change strings but the existing property/entity already has an OK name, we usually append a number.

Please add a LOCALIZATION NOTE saying what Chad says in comment 0: the string should be consistent with the Apps menu item in the Tools menu and the Apps toolbar button in Firefox's customization palette.  More about localization notes here: https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Add_localization_notes

The Tools menu string is webapps.label in browser.dtd: http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.dtd#222

The toolbar button label is web-apps-button.label in customizableWidgets.properties: http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/customizableui/customizableWidgets.properties#107

In your localization note, you should describe those other two usages of "Apps" both in English (e.g., "the Apps menu item in the Tools menu and the Apps toolbar item") and in terms of property/entity names and the files they live in (i.e., "webapps.label in browser.dtd and web-apps-button.label in customizableWidgets.properties").
Mentor: adw
Flags: needinfo?(adw)
(Assignee)

Comment 13

3 years ago
Created attachment 8613904 [details] [diff] [review]
replace_marketplace_label.patch.v2
Attachment #8608562 - Attachment is obsolete: true
Attachment #8613904 - Flags: review?(adw)
Summary: Rename "Marketplace" link on new tab page → Rename "Marketplace" link on about:home
Created attachment 8614182 [details] [diff] [review]
landed patch

Thanks, Baptiste.  The patch didn't apply cleanly because in aboutHome.dtd it's removing an "Apps" entity that doesn't exist.  (It should be "Marketplace".)  And for future reference, please use spaces instead of tabs.  (See style guide here: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Coding_Style)

I fixed those things and committed your patch to our fx-team repo.  The bug is now practically done, but it won't be marked as fixed until your change is merged into the mozilla-central repo.  Thanks!

https://hg.mozilla.org/integration/fx-team/rev/da1d9b5dda90
Attachment #8613904 - Attachment is obsolete: true
Attachment #8613904 - Flags: review?(adw)
Attachment #8614182 - Flags: review+
(Assignee)

Comment 16

3 years ago
Great, thanks for your time and your advices.
https://hg.mozilla.org/mozilla-central/rev/da1d9b5dda90
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Reporter)

Comment 18

3 years ago
Hi,
To clarify- when will the change be visible to users? I'm still seeing "marketplace"

Comment 19

3 years ago
I have reproduced this ug in Nightly 41.0a1(Build ID: 20150519030202)(User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0)


Bug is fixed now on latest Developer Edition 41.0a2 (Build ID: 20150629134017) User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

& latest nightly 42.0a1 (Build ID: 20150630030204) User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
QA Whiteboard: [Bugday-20150701]
Whiteboard: [Bugday-20150701]

Comment 20

3 years ago
I have reproduced the bug in Nightly 41.0a1 (2015-05-19)(Build ID: 20150519030202)with the instruction from comment 0 and linux 32 bit

Mozilla/5.0 (X11; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0


Bug is fixed now on latest Developer Edition 41.0a2 (2015-06-30)(Build ID: 20150630004006)
Mozilla/5.0 (X11; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0

& latest nightly 42.0a1 (2015-06-30)(Build ID: 20150630030204)
Mozilla/5.0 (X11; Linux i686; rv:42.0) Gecko/20100101 Firefox/42.0

Comment 21

3 years ago
As per comment 20 Changing the Status as Verified.
Status: RESOLVED → VERIFIED
status-firefox41: fixed → verified
You need to log in before you can comment on or make changes to this bug.