In-line paired devices appear in both 'Paired devices' and 'Devices in the area' sections of Settings app

VERIFIED FIXED in 2.2 S13 (29may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ben.tian, Assigned: iliu)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments, 2 obsolete attachments)

Reporter

Description

4 years ago
Pre-condition:
  Setting app has already launched and exists in background.

STR:
  1) Open gallery app, share -> Bluetooth
  2) Pair with one discovered device, and accept pairing request.
  3) Switch to Settings app -> Bluetooth panel

Expected Result:
  The paired device appears in "Paired devices" section only

Actual Result:
  The paired device appears in both "Paired devices" and "Device in the area" sections

Reproduction rate: 100%
Reporter

Comment 1

4 years ago
Ian, please help on this bug per offline discussion and investigation.
Assignee: nobody → iliu
See Also: → 1164314
Reporter

Comment 2

4 years ago
Nominate for 2.2?
blocking-b2g: --- → 2.2?
Status: NEW → ASSIGNED
in‑moztrap? for inline pairing case
Flags: in-moztrap?(echang)
Comment on attachment 8609219 [details] [review]
[gaia] ian-liu:bluetooth/bug1166636_remove_paired_device_from_found_device_list_while_inline_pairing_via_bluetooth_app > mozilla-b2g:master

The root cause is that Settings/Bluetooth apps only remove device paired from found device list if the device is paired by apps-self. 

In order to check the pairing action which is triggered by app-self, there is already existed 'pairingAddress' flag for identification. To considerate side effect and APIv1/v2 migration, I give a patch to fix the problem with minimise modification.

Arthur, could you please help to review my pr? Thanks.
Attachment #8609219 - Flags: review?(arthur.chen)
Comment on attachment 8609219 [details] [review]
[gaia] ian-liu:bluetooth/bug1166636_remove_paired_device_from_found_device_list_while_inline_pairing_via_bluetooth_app > mozilla-b2g:master

The patch is sane and the impact seems minimal. r=me, thanks!
Attachment #8609219 - Flags: review?(arthur.chen) → review+
Thanks for Arthur's reviewing effort. Since the patch is landed, we can close the issue.

Gaia/master: https://github.com/mozilla-b2g/gaia/commit/348f579664428ed95e949d8d4baf13b7a0ba13d8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8609219 [details] [review]
[gaia] ian-liu:bluetooth/bug1166636_remove_paired_device_from_found_device_list_while_inline_pairing_via_bluetooth_app > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): uncompleted UI updating flow for Bluetooth inline pairing
[User impact] if declined: per STR, the device paired is still in found device list
[Testing completed]: manual test, and no test broken on try-server
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8609219 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Keywords: verifyme
Norry,
please verify on master. Thanks
Flags: needinfo?(fan.luo)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Hi Verson, Please NI me if patch verify fail.
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(iliu)
Target Milestone: --- → 2.2 S13 (29may)
Hi Ryan,

I have requested Gaia v2.2 approval for this patch. Please kindly re-check on the attachment field. Thanks.
Flags: needinfo?(iliu) → needinfo?(ryanvm)
Release Management handles approvals, not me.
Flags: needinfo?(ryanvm)
Posted video verrify_3.0.mp4
This bug has been verified as pass on latest build of Flame v3.0,Nexus5 v3.0,by the STR in Comment 0 
Actually Result:The paired device appears in "Paired devices" section only
Reproduce rate:0/5
See attachment:Verify_3.0.mp4

Device:Flame v3.0 build(pass)
Build ID               20150526160204
Gaia Revision          8ca93673869a64e09ed6153c5402896822dfb253
Gaia Date              2015-05-26 19:31:37
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e4e369822ac
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150526.195035
Firmware Date          Tue May 26 19:50:45 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus 5 v3.0 build(pass)
Build ID               20150526160204
Gaia Revision          8ca93673869a64e09ed6153c5402896822dfb253
Gaia Date              2015-05-26 19:31:37
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e4e369822ac
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150526.195039
Firmware Date          Tue May 26 19:50:56 EDT 2015
Bootloader             HHZ11k
Attachment #8610512 - Attachment is obsolete: true
Attachment #8610513 - Attachment is obsolete: true
Comment on attachment 8609219 [details] [review]
[gaia] ian-liu:bluetooth/bug1166636_remove_paired_device_from_found_device_list_while_inline_pairing_via_bluetooth_app > mozilla-b2g:master

Hi Norry,

Please verify on 2.2 after you confirm patch is landed there.
Thanks!
Flags: needinfo?(fan.luo)
Attachment #8609219 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
Posted video Verify_2.2.mp4
This bug has been verified as pass on latest build of Flame v2.2, Nexus5 v2.2, by the STR in Comment 0 
Actually Result:The paired device appears in "Paired devices" section only
Reproduce rate:0/8
See attachment:Verify_2.2.mp4

Device:Flame v2.2 build(pass)
Build ID               20150527162504
Gaia Revision          0f162853ae6a3e2b05164878e49276ead0d6f09c
Gaia Date              2015-05-27 22:50:51
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2efe1d20e12
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.195632
Firmware Date          Wed May 27 19:56:46 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus 5 v2.2 build(pass)
Build ID               20150527162504
Gaia Revision          0f162853ae6a3e2b05164878e49276ead0d6f09c
Gaia Date              2015-05-27 22:50:51
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2efe1d20e12
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150527.195418
Firmware Date          Wed May 27 19:54:38 EDT 2015
Bootloader             HHZ11k
Status: RESOLVED → VERIFIED
Flags: needinfo?(fan.luo)
Keywords: verifyme
Flags: in-moztrap?(echang) → in-moztrap?(twen)

Comment 21

4 years ago
Added in Bluetooth suite https://moztrap.mozilla.org/manage/case/16268/
Flags: in-moztrap?(twen) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.