Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

({regression})

Trunk
mozilla41
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed)

Details

Here's a profile I collected using talos + tscrollx locally:
http://people.mozilla.org/~bgirard/cleopatra/#report=d31a5c7172f44819c8bea57452641bbe375a06f0

There are lots of gaps in both threads, some up to 15ms long. (The giant gaps are intentional and caused by pausing+resuming the profiler from the test.)

15ms of missing samples make a profile pretty useless.

I collected another profile under the same conditions, but with bug 1150252 backed out:
http://people.mozilla.org/~bgirard/cleopatra/#report=0a394a062b9fdf190ae827f02f97032d39d078e9
This still has some gaps, but those are usually just one missed sample, and not 15.

From that we can conclude that bug 1150252 is the cause.
https://hg.mozilla.org/mozilla-central/rev/fa8b4c399044
Assignee: nobody → mstange
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.