Closed Bug 1167052 Opened 9 years ago Closed 9 years ago

During configure step of build, we have this error output: "configure: 28673: test: Illegal number" (from ANDROID_VERSION check when that variable is undefined)

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox41 affected)

RESOLVED DUPLICATE of bug 1165733
Tracking Status
firefox41 --- affected

People

(Reporter: dholbert, Unassigned)

References

Details

(Keywords: regression)

Noticed this today in my build output, after clobbering:
{
 0:08.69 checking for stdint.h... yes
 0:08.71 checking for inttypes.h... yes
 0:08.74 checking for sys/int_types.h... no
 0:08.83 checking for posix_fadvise... yes
 0:08.87 checking for posix_fallocate... yes
 0:08.92 /scratch/work/builds/mozilla-inbound/mozilla/configure: 28573: test: Illegal number:
 0:08.94 updating cache ./config.cache
}

That "Illegal number:" error is pointing to this line of ./configure:
> elif test -n "$gonkdir" -a "$ANDROID_VERSION" -ge 17; then

This line was added (in build/autoconf/icu.m4) in bug 866301.

I verified that I get this error output on a build updated to the commit that added this line -- mozilla-central changeset 15a67288fd6f -- and I don't get the error if I update to the parent of that commit. Hence, regression from that commit (bug 866301).
I hit this when doing a clobber-build of Firefox for 64-bit Linux Desktop, with a minimal mozconfig & also with no mozconfig at all. Based on the error output, it looks like ANDROID_VERSION is undefined (which isn't surprising, because I'm not building for Android.

:m_kato, do you know what's going on here? Is it unexpected that we're evaluating this line on desktop builds?


(I guess this bug really belongs in Core:BuildConfig, since it's in a .m4 file that feeds into configure. --> reclassifying)
Component: JavaScript: Internationalization API → Build Config
Flags: needinfo?(m_kato)
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(m_kato)
Resolution: --- → DUPLICATE
Note this doesn't actually break anything.
Yup. Thanks for duping, sorry for not noticing the dupe when filing. (& glad to see the dupe's patch has landed!)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.