Closed Bug 1167097 Opened 6 years ago Closed 6 years ago

we don't send a loadedmetadata event in response to video.load() when preload is none

Categories

(Core :: Audio/Video, defect)

29 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1165203

People

(Reporter: hsteen, Unassigned)

References

()

Details

Demo: go to
http://www.w3.org/2010/05/video/mediaevents.html
and click/tap the "load()" button. In other browsers, note how the counter for loadedmetadata goes up to 1 and the square turns green after a few seconds of loading. In Firefox this counter doesn't move until you click the play() button.

This bug is spun off from bug 1165203 and there's relevant discussion from comment 10 onwards:
https://bugzilla.mozilla.org/show_bug.cgi?id=1165203#c10

Roc's second suggestion seems sensible and well supported - it is:

2) If the current resource load was triggered by load(), treat PRELOAD_NONE as PRELOAD_METADATA.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165203
You need to log in before you can comment on or make changes to this bug.