XML XSL PI testcase wrong

RESOLVED DUPLICATE of bug 226823

Status

Developer Documentation
General
--
trivial
RESOLVED DUPLICATE of bug 226823
16 years ago
5 years ago

People

(Reporter: Jerry, Assigned: Dawn Endico)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    

according to w3c, 
XSL PI can only in prolog of xml file, not allowed in elements.
So the testcase of this url is wrong

Reproducible: Always
Steps to Reproduce:
1.access http://mozilla.org/quality/browser/standards/xml/pi_in_root_element.xml
2.
3.
(Reporter)

Comment 1

16 years ago
http://mozilla.org/quality/browser/standards/xml/pi_in_child_element.xml
http://mozilla.org/quality/browser/standards/xml/pi_after_root_element.xml

the same error
link to spec:

http://www.w3.org/TR/xml-stylesheet/

The paragraph right before the first Note says: "The xml-stylesheet processing 
instruction is allowed only in the prolog of an XML document"

Comment 3

16 years ago
accepting QA for mozilla developer docs.

some of these bugs have been around for a _long_ time. Reporters, would you
please review the bugs, see if the issues have been resolved, and close bugs
appropriately.

I will do a full review of all bugs not touched in one week (8th April). 

Thanks.

</spam>
QA Contact: endico → imajes
(Reporter)

Comment 4

16 years ago
the bug is still there.
just remove them from testcase list.that's ok

Comment 5

14 years ago
I removed the tests from the list. Leaving this open to remove the tests from cvs.
Depends on: 226823
Blocks: 226823
No longer depends on: 226823
*** This bug has been marked as a duplicate of 226823 ***

*** This bug has been marked as a duplicate of 226823 ***
No longer blocks: 226823
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Depends on: 226823
Resolution: --- → DUPLICATE

Updated

13 years ago
No longer depends on: 226823
Component: Mozilla Developer → Documentation Requests
Product: Documentation → Mozilla Developer Center
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.