latest linux (Fedora) Java plugin broken on Firefox 38.0

RESOLVED DUPLICATE of bug 1165286

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1165286
2 years ago
2 years ago

People

(Reporter: mchristi, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511091651

Steps to reproduce:

latest linux Java plugin broken on Firefox 38.0:
Linux Fedora 20/21 64bit
Firefox 38.0

Java Plug-in 11.45.2.14
Using JRE version 1.8.0_45-b14 Java HotSpot(TM) 64-Bit Server VM

visit java test site:
https://www.java.com/en/download/installed.jsp?detect=jre
Detecting Java on your computer
Activate Java
Allow Now
Error. Click for details


Actual results:

NullPointerException
Error while initializing managers

Java Console
Java Plug-in 11.45.2.14
Using JRE version 1.8.0_45-b14 Java HotSpot(TM) 64-Bit Server VM
User home directory = /home/*****
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
java.lang.NullPointerException
	at sun.plugin2.applet.JNLP2Manager.initialize(Unknown Source)
	at sun.plugin2.main.client.PluginMain.initManager(Unknown Source)
	at sun.plugin2.main.client.PluginMain.access$200(Unknown Source)
	at sun.plugin2.main.client.PluginMain$2.run(Unknown Source)
	at java.lang.Thread.run(Thread.java:745)
Error while initializing manager: java.lang.NullPointerException, bail out



Expected results:

java should have been verified as correctly installed.

previous version of java on the same fedora system works.
(Reporter)

Comment 1

2 years ago
last comment in above post is incorrect.  It should read:
previous version of firefox, with the same Java Plug-in 11.45.2.14, worked well.

Comment 2

2 years ago
Are you behind a proxy?

If so, then this is probably the same as in bug 1165286
(Reporter)

Comment 3

2 years ago
Yes, I am behind a proxy.  I tested without using a proxy and the java plugin worked as expected.
Marking bug as resolved duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165286
You need to log in before you can comment on or make changes to this bug.