[Browser][YouTube] The URL that is displayed on the fullscreen allow prompt displays uneeded information

VERIFIED FIXED in Firefox 41, Firefox OS master

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: DerekH, Assigned: Bobby Holley (On Leave Until June 11th))

Tracking

({regression})

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], URL)

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 8608979 [details]
Youtube URL logcat

Description:
The URL that displays when the user tries to access a fullscreen YouTube video shows extra text that is unecessary. It seems to be the same line of text that is added no matter what YouTube video is being watched.


Repro Steps:
1) Update a Flame to 20150521142045
2) Open Browser app> Navigate to www.YouTube.com
3) Select any video, or search any video and select it
4) Tap on the fullscreen button


Actual:
The prompt tells the user "http://m.youtube.com!appld=1029&inBrowser=1 is now fullscreen."


Expected:
The prompt tells the user "http://m.youtube.com is now fullscreen."

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150521142045
Gaia: 208ec11c33c9bd2fab7fcf8647bc162c9f3d484f
Gecko: e5d4a9bc3e23
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/sflx6Z_0h70
This issue does NOT occur on Flame 2.2

The prompt tells the user "http://m.youtube.com is now fullscreen."

Environmental Variables: 
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150521002508
Gaia: bc42fbc12d622bffd7e8afcb8d56f8a1d9773c60
Gecko: 6e4eaf59efda
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
blocking-b2g: --- → 3.0+
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]

Updated

3 years ago
Assignee: nobody → jthomas
Assignee: jthomas → nobody
QA Contact: jthomas

Comment 2

3 years ago
Mozilla Inbound Regression Window

Last Working 
Environmental Variables
BuildID: 20150520170237
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: d98d6c08d2fd
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520171942
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 810c13b0ac02
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Last Working gaia / First Broken gecko - Issue DOES reproduce
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 810c13b0ac02

First Broken gaia / Last Working gecko - Issue does NOT reproduce
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: d98d6c08d2fd

Mozilla Inbound Pushlog: 
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d98d6c08d2fd&tochange=810c13b0ac02

Issue appears to occur due to changes made in Bug 1165162
Blocks: 1165162
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Bobby, can you take a look at this please? This might have been caused by the work done on Bug 1165162.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bobbyholley)
Bobby: it might be worth adding a nsIPrincipal.humanReadableOrigin or some such? Which is what we'd display in UI? Or should we tell people to use nsIPrincipal.originNoSuffix?
(In reply to Jonas Sicking (:sicking) from comment #4)
> Bobby: it might be worth adding a nsIPrincipal.humanReadableOrigin or some
> such? Which is what we'd display in UI? Or should we tell people to use
> nsIPrincipal.originNoSuffix?

I guess it depends on whether we'd ever want to surface any of the origin attributes to the user. It's possible, I suppose, so humanReadableOrigin might make sense. But on the other hand, any description of the origin attributes would probably need to be localized, so it may not help very much.

I'll just do the simple thing for now, I guess.
Assignee: nobody → bobbyholley
Flags: needinfo?(pbylenga)
Flags: needinfo?(bobbyholley)
Created attachment 8610766 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v1

Derek, does this fix the problem?
Attachment #8610766 - Flags: review?(quanxunzhen)
Attachment #8610766 - Flags: feedback?(dharris)
Comment on attachment 8610766 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v1

This looks right to me, but I'm neither a peer of Browser WebAPI nor of Firefox. Redirect the review to :smaug.
Attachment #8610766 - Flags: review?(quanxunzhen) → review?(bugs)

Comment 8

3 years ago
Comment on attachment 8610766 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v1

well, we shouldn't then call it 'origin' in the message either, right?

Comment 9

3 years ago
Comment on attachment 8610766 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v1

So I think you should change the .origin in the message to .originNoSuffix and change also the receiver side, r+ with that.

(But I'm not a Firefox peer ;) )
Attachment #8610766 - Flags: review?(bugs) → review+
Bobby, I am unsure how to apply that gecko change and check the patch. However, if a build is provided, I would be able to push that to my device and check the bug then.
Flags: needinfo?(bobbyholley)
Comment on attachment 8610766 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v1

:dao probably could help review the Firefox part.
Attachment #8610766 - Flags: review?(dao)
Created attachment 8611003 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v2 r=smaug
Attachment #8610766 - Attachment is obsolete: true
Attachment #8610766 - Flags: review?(dao)
Attachment #8610766 - Flags: feedback?(dharris)
Attachment #8611003 - Flags: review?(fabrice)
Attachment #8611003 - Flags: review?(dao)
(In reply to Derek Harris [:DerekH] from comment #10)
> Bobby, I am unsure how to apply that gecko change and check the patch.
> However, if a build is provided, I would be able to push that to my device
> and check the bug then.

Apparently I can't generate a device image on try. So I guess I'll just push it blind and then you can verify in the next Nightlies. Alternatively, fabrice can verify (or flag somebody to verify) when he reviews.
Flags: needinfo?(bobbyholley)

Updated

3 years ago
Attachment #8611003 - Flags: review?(dao) → review+
Comment on attachment 8611003 [details] [diff] [review]
Use originNoSuffix for full-screen prompt. v2 r=smaug

Review of attachment 8611003 [details] [diff] [review]:
-----------------------------------------------------------------

Tested on device, works as expected.
Attachment #8611003 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/f6e115b4fef3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S13 (29may)
status-b2g-master: --- → fixed
This issue has been verified fixed on Flame 3.0. The dialog now says "http://m.youtube.com is now fullscreen."

Device: Flame (KK, 319MB, full flashed)
BuildID: 20150529010201
Gaia: e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gecko: f986e55c4e0b
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
status-b2g-v2.5: --- → verified
status-firefox39: --- → wontfix
status-firefox40: --- → wontfix
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.