Closed Bug 1167432 Opened 5 years ago Closed 4 years ago

[Browser][YouTube] Fullscreen view is shown before the prompt asking to allow or not is shown

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: dharris, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Attached file Fullscreen Logcat
Description:
When the user switches a youtube video to full screen they are shown the video in fullscreen view for about 1000ms before the screen asking if they want to allow fullscreen mode is prompted. This issue also occurs if the user selects "dismiss" once the prompt is given. 


Repro Steps:
1) Update a Flame to 20150521142045
2) Open Browser app> Navigate to www.YouTube.com
3) Select any video, or search any video and select it
4) Tap on the fullscreen button

Actual:
The Fullscreen view of the youtube video will be seen before the warning prompt


Expected:
The prompt for allowing fullscreen is shown immediatley

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150521142045
Gaia: 208ec11c33c9bd2fab7fcf8647bc162c9f3d484f
Gecko: e5d4a9bc3e23
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/RYTjLOw5PPM
This issue does NOT occur on Flame 2.2

The prompt for allowing fullscreen is shown immediatley

Environmental Variables: 
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150521002508
Gaia: bc42fbc12d622bffd7e8afcb8d56f8a1d9773c60
Gecko: 6e4eaf59efda
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: bzumwalt
QA Contact: bzumwalt
QA Contact: jthomas
Mozilla Inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520142944
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 8ab04584ba4a
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520152044
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 2040569ec5c4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko.
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 2040569ec5c4

First Broken gaia / Last Working gecko - This issue does NOT occur with working Gecko.
Gaia:b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 8ab04584ba4a

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8ab04584ba4a&tochange=2040569ec5c4

Issue appears to occur due to changes made in Bug 1053413
Blocks: 1053413
Flags: needinfo?(ktucker)
It doesn't take 1000ms for me, only ~300ms from the view being in fullscreen to the prompt on my Flame.

Anyway, it probably indicates that an async event is not as fast as the notification (which is possible because the notification seems to be sync). We probably should make all the MozDOMFullscreen:* events sync as well.
[Blocking Requested - why for this release]:
Visible regression
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Xidorn, can you take a look at this please? This looks to have been caused by the landing for bug 1053413.
Flags: needinfo?(ktucker) → needinfo?(quanxunzhen)
I can, after some other bugs.

May I ask what's the scheduled release date of b2g 3.0? I'll try not to block the release if there is enough time, but not the very present. Sorry.
Flags: needinfo?(quanxunzhen)
Depends on: 1168705
With bug 1168705 fixed, this bug should probably also be fixed, or at least become less annoying?
Can we test again based on comment 7?
Keywords: qawanted
We cannot test this on latest build due to youtube crashing bug 1186965. We'll look at this once that crash has been resolved.
Can we test again?
This issue no longer occurs on today's builds.  I did notice bug 1166075 while checking this issue though.

Actual Results: The Fullscreen prompt appears before the video is made full screen.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150727165113
Gaia: 302a448729ff2b336581cf94b66327ea836294c7
Gecko: d576f2cec511
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150727091245
Gaia: 302a448729ff2b336581cf94b66327ea836294c7
Gecko: d576f2cec511
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.