Closed Bug 116764 Opened 18 years ago Closed 18 years ago

Missing closing tags can change the layout of a page

Categories

(Core :: DOM: HTML Parser, defect, minor)

x86
All
defect
Not set
minor

Tracking

()

VERIFIED INVALID

People

(Reporter: bcroq, Assigned: harishd)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

I recently understood the meaning of the element declaration in the DTDs:

<!ELEMENT (TH|TD) - O (%flow;)* -- blabla -->

and particularly the "- O" syntax: it means that the opening tag is mandatory,
while the closing tag is optional. I tried to remove some optional closing tags
and tested some pages with different browsers and it seemed to work, but then I
tried to write a rounded box.

If you look at the given URL, both tables are declared the same way, the only
difference is that in the second table, I don't close the TR and TD tags (the
text inside the boxes can be removed, the problem is still present).

This is strange, this problem also happens with Internet Explorer (5.50.4807.2300)!
Parser problem, sounds like.
Assignee: karnaze → harishd
Component: HTMLTables → Parser
QA Contact: amar → moied
This is INVALID. The tables are not equivalent. In the second table with the
missing end-tags you have a newline and three spaces after the 1st image for
example. This will count as text to be rendered. See bug 60543 and bug 22274 for
details on the line-height property and strict layout.
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Keywords: testcase
OS: Linux → All
Resolution: --- → INVALID
Attached file Corrected testcase
Verified invalid as per Comment #2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.