Closed Bug 1167688 Opened 5 years ago Closed 5 years ago

test_persona_app.py: "AssertionError: 'app://uitest.gaiamobile.org' != u'app://uitest.gaiamobile.org!appId=1058'"

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-master affected)

RESOLVED FIXED
Tracking Status
b2g-master --- affected

People

(Reporter: onelson, Assigned: martijn.martijn)

References

()

Details

Attachments

(2 files)

Description:
test_persona_app.py is failing consistently in today's latest engineering for mozilla-central. An assert is flagged after performing a 'standard' login with a verified email [account appears to be generated per test, however this was tested with the tester's standard persona credentials].

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/55/HTML_Report/

Repro Steps:
1) Update to 20150522010227 [Engineering]
2) Open 'UI Tests' app
3) Tap 'API'
4) Tap 'persona mozId'
5) Perform Request tests -> Standard (verified email)
6) Login to persona account
7) Observe events

Actual:
Assertion on log in

Expected: 
Login successful

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/persona/test_persona_app.py", line 49, in test_persona_standard_sign_in
self.assertEqual(AUDIENCE, unpacked['payload']['aud'])
AssertionError: 'app://uitest.gaiamobile.org' != u'app://uitest.gaiamobile.org!appId=1058'


Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	22 May 2015 08:41:18
Device firmware (incremental) 	eng.cltbld.20150522.044107
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	f0694085
Device uptime 	0 days 0 hours 2 minutes 42 seconds
Gaia date 	21 May 2015 21:23:56
Gaia revision 	1126d8bee559
Gecko build 	20150522010227
Gecko revision 	3e737d30f842
Gecko version 	41.0a1

Reproducible manually: YES

Repro frequency: 6/6 observed in Automation

Could be related to bug 1162391, however the Traceback appears to have morphed with very consistent failures now.
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
If this can be reproduced manually, then
Assignee: nobody → martijn.martijn
Could this have been caused by bug 1165162?
It didn't happen with a 20150520 build.
Bobby, could this have been caused by bug 1165162, somehow?

B2G desktop returns app://uitest.gaiamobile.org!appId=58, on device it returns app://uitest.gaiamobile.org!appId=1058
I could easily change the test to make this work, but I need to know if the result we get is intentional or is something this is broken. Fernando, do you know, perhaps? (regarding the UITest->API/identity test).
Flags: needinfo?(ferjmoreno)
Flags: needinfo?(bobbyholley)
Btw, I also get this dialog after the test has run. That doesn't seem to be correct, either.
(In reply to Martijn Wargers [:mwargers] (QA) from comment #2)
> Could this have been caused by bug 1165162?
> It didn't happen with a 20150520 build.

Almost certainly. .origin now contains an extra suffix that contains a stringification of all the attributes which contribute to the origin (like appId and inBrowser). The goal is to maintain the invariant that prin1.equals(prin2) i.f.f. prin1.origin === prin2.origin.

You can use .originNoSuffix for situations where you don't care about this invariant.
Flags: needinfo?(bobbyholley)
Flags: needinfo?(ferjmoreno)
Comment on attachment 8610572 [details] [review]
[gaia] mwargers:1167688 > mozilla-b2g:master

Thanks for the explanation, that means we can simply use this solution.
Attachment #8610572 - Flags: review?(npark)
Attachment #8610572 - Flags: review?(jlorenzo)
Comment on attachment 8610572 [details] [review]
[gaia] mwargers:1167688 > mozilla-b2g:master

r+ modulo the nit on the use of assertTrue()
Attachment #8610572 - Flags: review?(jlorenzo) → review+
Ok, updated.
Attachment #8610572 - Flags: review?(npark) → review+
https://github.com/mozilla-b2g/gaia/commit/e7d268074ee3c9eeb191c2205c0e35992fb3915d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.