Polycraft Demo does not play since Firefox 38

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Todd Brais, Unassigned)

Tracking

({regression, site-compat})

Firefox 38
Unspecified
Windows 7
regression, site-compat
Dependency tree / graph

Firefox Tracking Flags

(firefox38 wontfix, firefox38.0.5 wontfix, firefox39+ wontfix, firefox40- affected, firefox41- affected, firefox-esr31 unaffected, firefox-esr38 affected)

Details

(Whiteboard: [betabreakers-fx40] [sitewait] [lib-turbulenz], URL)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8609562 [details]
fx40_Lothar_dxdiag.txt

Actual Result:
When the user selects to 'Play' the Polycraft Demo; the game does not load; instead the user receives an infinite loading loop; where the splash screen will reload
Note: Game loads fine when using google chrome

Expected Result:
Game loads on FF 40 without any issues

Steps to Reproduce:
1. With e10s enabled OR disabled; launch the 'Polycraft' demo
https://ga.me/games/polycraft

2. Click the 'Play' button, and observe that demo does not load
(Reporter)

Comment 1

3 years ago
Created attachment 8609563 [details]
fx40_Lothar_support.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [betabreakers-fx40]
Whiteboard: [betabreakers-fx40]

Comment 2

3 years ago
An error shown in Error console:

Error: TypeError: d.setData is not a function
Source File: https://d36kx37nk0bz9z.cloudfront.net/UL8x6Zt1aIlmd5Pg/S/XekgIicoqMGQnWhZXf65DV6awFI1m49A-HHijpA7-Y310b99.js
Line: 849

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0aa5dec4bf2a&tochange=5f26a8bdf93e

Triggered by:Bug 1121936, Bug 1121935
Status: UNCONFIRMED → NEW
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → affected
Component: Canvas: WebGL → JavaScript: Standard Library
Ever confirmed: true
Keywords: regression
Version: 40 Branch → 38 Branch

Updated

3 years ago
Blocks: 1121936, 1121935
Tom, do you have any thoughts on this regression?
Flags: needinfo?(evilpies)
[Tracking Requested - why for this release]: this is a regression which puts us at a competitive disadvantage.
tracking-firefox38: --- → ?
It's a site bug. ma.prototype.createTechniqueParameterBuffer has this code:

void 0 === Float32Array.prototype.map && (Float32Array.prototype.map = function (a, c) {
....
}
}
}, Float32Array.prototype.unmap = function () {
}, Float32Array.prototype.setData = function (a, c, d) {
...
});

Which basically means when the function Float32Array.prototype.map exists, this other function "setData" isn't even added to the prototype.
Flags: needinfo?(evilpies)
Is there something we can do to improve the situation here since it works fine in Chrome? or is this a straight up tech evangelism bug which we cannot fix?
We can backout the change, but it's a function defined in the ES6 standard, so I would rather not do that. We should try evangelism first.
Moving over to Tech Evangelism based on comment 7.

Martin, do you know if the Games team has any contact with the developer of this site?
Component: JavaScript: Standard Library → Desktop
Flags: needinfo?(mbest)
Product: Core → Tech Evangelism
Version: 38 Branch → Firefox 38
Summary: Firefox 40: Polycraft Demo does not play → Polycraft Demo does not play since Firefox 38

Updated

3 years ago
Keywords: dev-doc-needed, site-compat
It looks like the code from Comment 5 is actually part of the turbulenz_engine. So there are potentially lots more sites that will be affected. :/

<https://github.com/turbulenz/turbulenz_engine/blob/8f9ffd245fb05782352db959be0a979bbb7b6f1b/tslib/webgl/graphicsdevice.ts#L4916>
I see that Microsoft already reported an issue: https://github.com/turbulenz/turbulenz_engine/issues/43
Hey.  I can reach out to the CEO over at Turbulenz.
Flags: needinfo?(mbest)
Sent an email explaining the situation with a link to this bug.
Thank you Mike and Martin.
Whiteboard: [betabreakers-fx40] → [betabreakers-fx40] [sitewait]
Whiteboard: [betabreakers-fx40] [sitewait] → [betabreakers-fx40] [sitewait] [lib-turbulenz]
Turbulenz wrote back:

"Thank you - we are aware of the issue.

(Whilst the fix is simple, the deployment isn't - as we need to rebuild and redeploy all the games to include this fix.)"

Comment 15

3 years ago
Also occurs on Onyxia.  Included DxDiag.

Comment 16

3 years ago
Created attachment 8610680 [details]
ff40_onyxia_DxDiag.txt
Thanks for closing the loop, Martin. Is there anything we can do to work around this issue or do we simply have to live with it?
[Tracking Requested - why for this release]:
Too late for 38. Request tracking for 39 to make sure Liz sees it.
tracking-firefox38: ? → ---
tracking-firefox39: --- → ?
I'll ping again to figure out status.
Sounds like Martin and Turbulenz are handling this. Let's hope it's fixed before 39 goes to release at the end of June.
tracking-firefox39: ? → +
tracking-firefox40: --- → +
tracking-firefox41: --- → +
They let me know it is something they are working towards.  They don't have an ETA.  They have a resolution however.  They are working to distribute the fixes to places it's deployed which is the challenge.
Wontfix for 39. If this has been fixed by Polycraft then please update us. Thanks!
status-firefox38: affected → wontfix
status-firefox38.0.5: affected → wontfix
status-firefox39: affected → wontfix
Not tracking anymore. It seems that it is not really our fault. So, not point still tracking it.
tracking-firefox40: + → -
tracking-firefox41: + → -

Comment 24

3 years ago
Created attachment 8679141 [details]
OnyxiaOhNuts.bmp

Bug not fixed, however now it thinks the browser is out of date.

Comment 25

3 years ago
Note: Browser 43 was used to replicate.
Martin, any update from the developer given comment 24?
Flags: needinfo?(mbest)

Comment 27

3 years ago
Created attachment 8680174 [details]
OnyxiaOhNuts.bmp.tar.gz

compressed version

Comment 28

3 years ago
Created attachment 8680175 [details]
OnyxiaUntrusted.bmp.tar.gz

Comment 29

3 years ago
(In reply to Trammel May from comment #28)
> Created attachment 8680175 [details]
> OnyxiaUntrusted.bmp.tar.gz

disregard this file, it was from not from the regression test, but the original v43 test plan.
Attachment #8680175 - Attachment is obsolete: true

Updated

3 years ago
Keywords: dev-doc-needed
Not seeing any reaction from the developer.  They are aware of the problem and know what to do about it but we have not seen them take any action.  My sense is they are no longer pursuing the web as a primary target and are currently focused on console and native game releases so they are not putting resources behind a solution.
Flags: needinfo?(mbest)
I've added Andre to this bug who is now the Product person looking at games.  Turbulenz is the developer.
Just tested this to insure it's not working and I was able to get in in FF42 and play the game.  Can someone double check?
(In reply to Martin Best (:mbest) from comment #32)
> Just tested this to insure it's not working and I was able to get in in FF42
> and play the game.  Can someone double check?

Can you check Firefox 43? That's what Trammel used to test several days ago in comment 25.
Tested it in nightly (45) and no issue there.  Just getting beta.
just tested in 43, no issue.  The load bar sits for a bit but then goes through.
This bug was originally reported against the following systems:
* Lothar: Windows 7 32-bit with a NVIDIA GeForce 7300LE 256MB 
* Onyxia: Windows XP with dual NVIDIA GeForce 7950 GT 512MB in SLI

Hardware and/or platform may be a factor in reproducing this. Martin, what system are you running this on?

Comment 37

2 years ago
I just regressed this and it played fine. 

I am wondering if the original test didn't allow the browser enough time to load the game, as it did take about a minute. 

QA Confirmed: Fixed
Thanks, that seems to confirm what Martin reported earlier. I'm resolving this bug as WORKSFORME - please reopen if you have steps to reproduce in a current Firefox build.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.