plugin-container on GTK3 crashes running test layout/base/tests/chrome/test_chrome_over_plugin.xul

RESOLVED FIXED in Firefox 41

Status

()

Core
Widget: Gtk
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: acomminos, Assigned: acomminos)

Tracking

unspecified
mozilla41
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The test layout/base/tests/chrome/test_chrome_over_plugin.xul fails due to plugin-container crashing on GTK3 with the following error:

    The program 'plugin-container' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
      (Details: serial 280 error_code 9 request_code 14 minor_code 0)
      (Note to programmers: normally, X errors are reported asynchronously;
       that is, you will receive the error a while after causing it.
       To debug your program, run it with the --sync command line
       option to change this behavior. You can then get a meaningful
       backtrace from your debugger if you break on the gdk_x_error() function.)
(Assignee)

Comment 1

3 years ago
Created attachment 8611368 [details] [diff] [review]
Fixes invalid window ID provided to GTK3 plugin container children.

This fixes bustage caused by an outdated (pre-GTK3) macro.

Some tests in this suite still don't pass; I believe this to be unrelated and probably best tacked in a separate bug.
Attachment #8611368 - Flags: review?(karlt)
Attachment #8611368 - Flags: review?(karlt) → review+
(Assignee)

Comment 3

3 years ago
Oops; GTK3 try patch wasn't building.

Updated try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cf810f3da26d
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ee5c01c6659d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.