Closed Bug 1167753 Opened 6 years ago Closed 6 years ago

[Window Management] Number pad does not appear on SIM PIN screen when accessing cost control through notification tray after restart

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: ychung, Assigned: timdream)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Description:
(Expand upon the Summary - but not a copy of the Summary!)

Pre-requisite:
- SIM PIN is enabled.
- Usage app is set with Data use alert enabled with 1mb limit.
- Data Connection is enabled.

Repro Steps:
1) Update a Flame to 20150522001933.
2) Navigate through a webpage to generate data usage over 1mb.
3) When the notification "1 MB of data" used" appears, restart the device.
4) Move the slider to the right to unlock the device.
5) On SIM PIN screen, pull down the notification.
6) Select the data alert notification.
7) Select the input filed on SIM PIN screen.

Actual:
The number pad does not appear.

Expected:
The number pad appears automatically or appears when the input field is selected.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150522001933
Gaia: 1126d8bee559f7cde675df2fcc6c196da9cfeba1
Gecko: 3e737d30f842
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 5/5
See attached: video clip, logcat
https://youtu.be/LUWqmmSbe9s
This issue also reproduces on Flame 2.2.

Result: The number pad does not appear again on SIM PIN screen.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150522002508
Gaia: 9acbac7e6d4a2e3913af4aa202ea403501967fcd
Gecko: a1e8f172523d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------
When restating Flame 2.1, the data use alert notification does NOT reappear. 

Environmental Variables:
Device: Flame 2.1 (KK, 319mb, full flash)
Build ID: 20150522001205
Gaia: 0d343f49c0e0a3928a4f456faf98e37bb26a6ef6
Gecko: 23203116eac3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Broken Functionality.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
blocking-b2g: 3.0? → 3.0+
Component: Gaia::System::Window Mgmt → Gaia::System::Input Mgmt
Whiteboard: [3.0-Daily-Testing][systemsfe] → [3.0-Daily-Testing]
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Root cause:

InputWindowManager#hideInputWindowImmediately is called without removing the focus when 'notification-clicked' event is dispatched from notification_screen.js.

I am going to submit a patch that could ensure the focus is removed when the method is called.
(In reply to Yeojin Chung [:YeojinC] from comment #0)
> Repro frequency: 5/5
> See attached: video clip, logcat
> https://youtu.be/LUWqmmSbe9s

This is recoverable by tapping the empty space to manually remove the focus and try to re-focus again. Normally I won't say that's blocker but we could deal with this for now since the fix seems fairly easy.

However if this cause unlikely regressions we would have to consider back out the patch and unblock this bug.
Comment on attachment 8659061 [details] [review]
[gaia] timdream:input-mgmt-removeFocus-on-hideInputWindowImmediately > mozilla-b2g:master

Would you help review this?
Attachment #8659061 - Flags: review?(apastor)
Comment on attachment 8659061 [details] [review]
[gaia] timdream:input-mgmt-removeFocus-on-hideInputWindowImmediately > mozilla-b2g:master

Seems reasonable to me. Thanks!
Attachment #8659061 - Flags: review?(apastor) → review+
master: https://github.com/mozilla-b2g/gaia/commit/646bd3e09e9a87def791dd707d1f7bdcdf84edd5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Number pad appears on SIM PIN screen when accessing cost control through notification tray after restart.
See attachment: verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150913150208
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.184300
Firmware Date          Sun Sep 13 18:43:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150913195924
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150913.192006
Firmware Date          Sun Sep 13 19:20:14 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.