[APZ] Flashing contents from a different page before fixed background image loads

RESOLVED DUPLICATE of bug 1179010

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1179010
3 years ago
2 years ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

3 years ago
Steps to reproduce:
 1. Turn on e10s and APZ.
 2. Go to any page (e.g. this bug).
 3. Load http://www.smsvongesternnacht.de/ in the same tab.
 4. Go back and forwards as needed if you missed the bug.

Actual results:
While the new page is loading, you can briefly see content from the old page show up in the place where the fixed background image of the new page is going to be.

Expected results:
We should show the new page's background color in that part until the background image has loaded.
Whiteboard: [gfx-noted]
Blocks: 1178298
No longer blocks: 1157746
status-firefox41: affected → ---
(Reporter)

Comment 1

2 years ago
This is probably bug 1179010 and has nothing to do with APZ. Turning on APZ triggered this bug to show because the decode-on-draw pref was on by default but only took effect if APZ was on.
No longer blocks: 1178298
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179010
You need to log in before you can comment on or make changes to this bug.