Wrong size favicon.ico causes bug in image display

RESOLVED DUPLICATE of bug 160975

Status

()

RESOLVED DUPLICATE of bug 160975
17 years ago
16 years ago

People

(Reporter: usenet, Assigned: hyatt)

Tracking

(Blocks: 1 bug)

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

I created a favicon.ico for a web site. By mistake, I created it as 15x16,
rather than 16x16.

Reproducible: Always
Steps to Reproduce:
1. Put 15x16 favicon.ico on web site
2. Visit site with Mozilla


Actual Results:  favicon is displayed //skewed// at 45 degrees, with wrapround

Expected Results:  Either of the above would be OK:
a. Konqueror displays as 15x16, with one-pixel grey line at right
b. IE 5.5 displays by performing anamorphic stretch to 16x16, softening the
image in the process

presumably wrong stride is calculated in image library, using the expected
width, not the actual width?

The icon is also displayed wrong in the same way when rendered inline when
reading mail that has the icon file attached.

BUT: the icon _is_ displayed correctly when shown as file/icon in the 'attached
file' field in the messenger (running on Windows).
(Reporter)

Comment 1

17 years ago
Created attachment 62710 [details]
15x16 favicon.ico file, as per description in bug

This is the file that generated the incorrect result.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Note that just clicking on the 'Created an attachment (id=62710)' link above
displays a page with the icon displayed as per bug report.
(Reporter)

Comment 3

17 years ago
Using the appearance in the received mail pane as a test for this behaviour, I
note that, for testing all 4 combinations of 17 and 18 pix wide, 4 and 8 bpp
deep, at a constant depth of 16 pixels:
* the icon is mis-displayed for both 17 and 18 pix wide 
* changing from 4 bpp to 8 bpp does not make any difference to the appearance

Comment 4

17 years ago
->hyatt
Assignee: pavlov → hyatt

Updated

17 years ago
Blocks: 120352
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

16 years ago
*** Bug 165388 has been marked as a duplicate of this bug. ***
marking dup of bug 160975 which has a patch

*** This bug has been marked as a duplicate of 160975 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.