Status

support.mozilla.org
BuddyUp
P1
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spark])

As part of Spark, we will be using a device which isn't on the list here, https://github.com/mozilla/buddyup/blob/0ac6c589da9e60fbebd2c9a55cf583fcc71c7e91/app/js/utils.js#L25.

Therefore, when you post questions from that device, it doesn't identify the device. I will try to get the user agent from the phone.
Is the device for Spark using a different user agent? If it doesn't, we'll be in the same spot as the Flame and we can't identify it.
Flags: needinfo?(mozillamarcia.knous)
Adding Doug to weigh in here.
Flags: needinfo?(mozillamarcia.knous) → needinfo?(drs)
Fabrice, Dave, what do you think about just adding "Spark" to the user agent when built using the Spark customization? We can ask the loop people to publish a new Hello app to Marketplace with "Spark" whitelisted.

We might also want "ALCATELOneTouch6015X" in the interim, despite this not being the actual device. That way, if they don't publish the new version for us in time, the client will still work.
Flags: needinfo?(fabrice)
Flags: needinfo?(drs)
Flags: needinfo?(dale)
I have a similiar issue in https://bugzilla.mozilla.org/show_bug.cgi?id=1149012 where I am looking to pick up identifying information of the build we are running, I would be surprised if touching the user agent was a good idea though, I also had to ask Fabrice + Jonas about this.
Flags: needinfo?(dale)
(In reply to Dale Harvey (:daleharvey) from comment #4)
> I have a similiar issue in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1149012 where I am looking to
> pick up identifying information of the build we are running, I would be
> surprised if touching the user agent was a good idea though, I also had to
> ask Fabrice + Jonas about this.

I don't see a way to do this, other than user agent sniffing, while still allowing us to use the version of Hello on Marketplace. Perhaps we could fork it instead, but that seems unnecessary.

Do you have any ideas?

Also adding Jonas based on similarities to bug 1149012.
Flags: needinfo?(jonas)
Blocks: 1111748
Priority: -- → P1
We can turn on device ID in the UA string, by setting the general.useragent.device_id preference. That's doable in the device tree.
Flags: needinfo?(fabrice)
I don't know enough about Hello to understand what the problem is here.

Touching the UA header is rarely a good idea, as others have pointed out. But I need to understand the problem better to provide a specific proposal.
Flags: needinfo?(jonas)
SUMO has moved to Lithium and this bug is for a SUMO project that isn't around anymore. Given that, I'm closing as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.