Status

MailNews Core
MIME
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Aleksey, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8609859 [details]
One of the messages, which is not shown in thunderbird

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511103818

Steps to reproduce:

I received some messages from SDL bugzilla.


Actual results:

All of this messages looks like empty (no content) in Thunderbird. But it ave some text in source. Example message attached to this bug.


Expected results:

Expected: normal text in message window. 

Please check is this problem in Thunderbird or all this messages are incorrect. I'm sorry if this problem because of incorrect messages.

Comment 1

3 years ago
I can confirm TB renders the attached message as empty.

But I think the message has incorrect headers inside the alternative sections. E.g. there is:
--1416559401.3FbEf0.18214
Date: Fri, 21 Nov 2014 08:43:21 +0000

MIME-Version: 1.0

Content-Type: text/html

If you remove the empty lines between the headers, the message will render fine.

Jcranmer, can you confirm this is an invalid message? Or is this a variant allowed by the spec?
Component: Untriaged → MIME
Flags: needinfo?(Pidgeot18)
OS: Unspecified → All
Product: Thunderbird → MailNews Core
Hardware: Unspecified → All
(Reporter)

Comment 2

3 years ago
Yes, if I remove empty lines in sections headers, then this message displayed correct.
Does this mean this is incorrect messages?
I have 9 messages like this and all of them displayed as empty.
(In reply to :aceman from comment #1)
> I can confirm TB renders the attached message as empty.
> 
> But I think the message has incorrect headers inside the alternative
> sections. E.g. there is:
> --1416559401.3FbEf0.18214
> Date: Fri, 21 Nov 2014 08:43:21 +0000
> 
> MIME-Version: 1.0
> 
> Content-Type: text/html
> 
> If you remove the empty lines between the headers, the message will render
> fine.
> 
> Jcranmer, can you confirm this is an invalid message? Or is this a variant
> allowed by the spec?

An empty line terminates the header block and commences the body. What's probably happening, I suspect, is that some tool is translating the CRLF combos into two LFs that are then getting converted into CRLFs individually, i.e.:
Date: ...\r\nMIME-Version: 1.0
became
Date: ...\n\nMIME-Version: 1.0
became
Date: ...\r\n\r\n\MIME-Version: 1.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(Pidgeot18)
Resolution: --- → INVALID

Comment 4

3 years ago
Aleksey, our recommendation is that you report the problem to the sender of these emails so that he should fix his application generating these invalid messages.
Flags: needinfo?(alexlsh)
(Reporter)

Comment 5

3 years ago
Ok, thanks. I report it to sender. I see this problem somewhere in their software.
(Reporter)

Comment 6

2 years ago
I see this bug still marked as "needinfo". Please specify what exactly info you waiting from me? 
I'm sure you are right this is not TB bug, but incorrect messages. All this messages are auto-created and sent by Bugzilla at https://bugzilla.libsdl.org/. SDL devs using Bugzilla version 5.0.2. 
Possible this is a bug in that version of Bugzilla or SDL devs incorrectly configured their Bugzilla installation. I'm not an admin on that site, I'm just a user and I can't check configuration. 
If you need more info from me, please specify which and I give you any information if I can.
You need to log in before you can comment on or make changes to this bug.