[RTSP][Open C] "Video playback aborted due to a network error" appears when trying to play Orange Caraïbe Live TV streams

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: mgperso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8610259 [details]
logcat.txt

Device informations :
ZTE Open C FR.
OS version: 2.2.0.0-prelease
Build number: eng..20140806.064432
Platform version: 37.0

Steps to reproduce :
(impossible to reproduce if you're not in Orange Caraïbe network)
- Browse http://3g.orangecaraibe.com/tv
- Choose a tv to watch
- Click the play link

Happened : The video player opens, but this message appears : "Video playback aborted due to a network error".

Expected : The live TV stream plays fine.

What's version of B2G : All


As I said, it's impossible to open the link, if you're not in Orange Caraïbe network (the play link don't appear). But I attached a logcat of what happened. Moreover, I got that with 'cat /proc/kmsg' :
<3>[05-19 23:49:06.769] BMS: recalculate_soc: batt_temp phy = 341 meas = 0xc06a8258c1411f0c
<6>[05-19 23:49:10.098] msm_vidc: 4: Opening video instance: de2c0000, 1
<6>[05-19 23:49:10.133] audio_open:AAC 5.1 Decoder OPEN success mode[1]session[1]
<3>[05-19 23:49:10.281] audio_aio_ioctl[cf7f9e00]:AUDIO_SET_CONFIG
<3>[05-19 23:49:10.286] audio_ioctl:AUDIO_SET_AAC_CONFIG: Invalid dual_mono mode =65535
<6>[05-19 23:49:10.293] q6asm_media_format_block_multi_aac:format=3 cfg_size=12 aac-cfg=3 aot=2 ch=2 sr=48000
<6>[05-19 23:49:10.295] audio_ioctl: AUDIO_START sessionid[1]enable[1]
<6>[05-19 23:49:10.969] msm_vidc: 4: Closed video instance: de2c0000
(Reporter)

Comment 1

3 years ago
I precise that other phones, like an old Nokia I have play these rtsp stream nicely.

When I passed my Open C on Android KitKat (to test), I was also able to watch TV.
(Reporter)

Comment 2

3 years ago
Created attachment 8610262 [details]
logcat_android.txt

This is a logcat made on KitKat, when I watched live TV.

I noticed these lines :
I/ARTSPConnection(  268): status: RTSP/1.0 200 OK
I/MyHandler(  268): DESCRIBE completed with result 0 (Success)
I/ASessionDescription(  268): v=0
I/ASessionDescription(  268): o=- 1382796211 1382796211 IN IP4 127.0.0.1
I/ASessionDescription(  268): s=WowzaMediaServer
I/ASessionDescription(  268): c=IN IP4 0.0.0.0
I/ASessionDescription(  268): t=0 0
I/ASessionDescription(  268): a=sdplang:en
I/ASessionDescription(  268): a=range:npt=now-
I/ASessionDescription(  268): a=control:*
I/ASessionDescription(  268): m=audio 0 RTP/AVP 96
I/ASessionDescription(  268): a=rtpmap:96 MP4A-LATM/48000/2
I/ASessionDescription(  268): a=fmtp:96 profile-level-id=15;object=2;cpresent=0;config=400023203FC0
I/ASessionDescription(  268): a=control:trackID=1
I/ASessionDescription(  268): m=video 0 RTP/AVP 97
I/ASessionDescription(  268): a=rtpmap:97 H264/90000
I/ASessionDescription(  268): a=fmtp:97 packetization-mode=1;profile-level-id=42C015;sprop-parameter-sets=Z0LAFdkAkCv5//AC0AQBAAADAAF3NZQADxYuSAA=,aMuBdyA=
I/ASessionDescription(  268): a=cliprect:0,0,324,576
I/ASessionDescription(  268): a=framesize:97 576-324
I/ASessionDescription(  268): a=framerate:1.0E9
I/ASessionDescription(  268): a=control:trackID=2
I/ARTSPConnection(  268): status: RTSP/1.0 200 OK
(Reporter)

Comment 3

3 years ago
It seems that there is a bug to support SDP protocol. Perhaps my bug depends on it.
Depends on: 929907
Summary: [RTSP] Orange Caraïbe Live TV streams don't work → [RTSP][Open C] Orange Caraïbe Live TV streams don't work
(Reporter)

Updated

3 years ago
No longer depends on: 929907
Summary: [RTSP][Open C] Orange Caraïbe Live TV streams don't work → [RTSP][Open C] "Video playback aborted due to a network error" appears when trying to play Orange Caraïbe Live TV streams
(Reporter)

Comment 4

3 years ago
Hello,

I realised some tests with my phone on modem mode, on Debian with softwares available at www.live555.com : live555ProxyServer (rtsp proxy server) and openRTSP (tool giving informations about an opened stream).

Test 1 : I tried to open the stream normally, and also got informations with openRTSP.
Obviously, it fails on the phone, as before.

Test 2 : Always with my phone in modem mode, I used live555ProxyServer to access to the stream, and I used openRTSP on the proxy to get informations again.
When I opened the stream through the proxy server, the phone successfully opened the stream.

The only information I discovered is that Wowza Media Server is used, to stream TVs. I don't understand what is different between access the stream directly, and through a proxy.
Someone has an idea about that ? If more information is needed to resolve this bug, please ask me, and I will try to provide them.
(Reporter)

Comment 5

3 years ago
Created attachment 8671064 [details]
Result from Test 1 with openRTSP
(Reporter)

Comment 6

3 years ago
Created attachment 8671067 [details]
Result from Test 2 with openRTSP
(Reporter)

Comment 7

3 years ago
If it can help, when I read logcat for different tries, the flow is always the same as in provided logcat.txt : after 19 "requestBuffer / dequeueBuffer", this line appear :
W/ALooperRoster(  301): failed to post message. Target handler 13 still registered, but object gone.

Moreover, the issue was already present in 2.1.

Comment 8

3 years ago
Jonathan,

Could you help to investigate this issue when you have time?
As the reported said in comment 0, we could not reproduce this bug. So we can only try to find some clues from the logs he provided.
The reported b2g version is 2.2. Perhaps it could be some issue we fixed after this version.
Flags: needinfo?(jhao)
Assignee: nobody → jhao
Flags: needinfo?(jhao)
(Reporter)

Comment 9

3 years ago
The build number (eng..20140806.064432) concerns the base image of my Open C FR (rooted).

I regularly update gecko and gaia. Here is git commit informations for current 2.2 :
2015-10-07 13:05:24
885647d9
Thanks for the information you provided, but it's really hard to diagnose the problem without a link at hand to reproduce.

Are you sure there's no way we can open streams in Orange Caraïbe network?
Or, could you reproduce this bug on other public links?

Thank you.
(Reporter)

Comment 11

3 years ago
I tried to reproduce the bug, without success. I also searched live stream broadcasted by Wowza Media Server on internet, and found nothing.
The only solution I see to try reproducing the bug, is having Wowza Media Server, and broadcast a live stream with it.
(In reply to micgeri from comment #11)
> I tried to reproduce the bug, without success. I also searched live stream
> broadcasted by Wowza Media Server on internet, and found nothing.
> The only solution I see to try reproducing the bug, is having Wowza Media
> Server, and broadcast a live stream with it.

Okay, we could try to set up a Wowza Media Server in order to reproduce it.

Meanwhile, Micgeri, could you capture the packets from your FxOS device and upload them in pcap format? That could be quite helpful for problem analysis.
Flags: needinfo?(mgperso)
In case you don't have experience to capture packets on FxOS phones. Here are the steps:
1. Push tcpdump-arm into the device.
2. Execute command:
   # tcpdump-arm -i wlan0 -s 0 -w <pcap-filename>
3. Pull the pcap file and use Wireshark open the it.
4. Filter RTSP and RTP packets by typing "rtsp || rtp" in the Filter field of Wireshark.
(Reporter)

Comment 14

3 years ago
Ok. It seems that the Open C has already a binary named tcpdump, so I will use it.
Just for sure, do I dump the wlan card (wlan0) while I'm reading stream with my computer, or the modem phone card (rmnet0) while I'm trying to open the stream with my FxOS device ?
Flags: needinfo?(mgperso)
(Reporter)

Comment 15

3 years ago
Created attachment 8673900 [details]
Packet capture from FxOS when trying to open Orange Caraïbe live stream
Unassigned myself since I'm not actively working on Firefox OS anymore.
Assignee: jhao → nobody
Close this bug because RTSP in FxOS is rarely used by users.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.