[FFOS7715 v2.1] [dolphin&flame][music] Music UI displayed abnormal.

VERIFIED FIXED in 2.2 S14 (12june)

Status

defect
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lin.hui, Assigned: chens)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 wontfix, b2g-v2.1 wontfix, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master unaffected)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
Steps to reproduce:
----------------------------------------------------
1. when music app doing scanning, click search bar, once scanning ended, the UI displayed abnormal.

Captured a video for further description:
  Video path: ftp://ftp.spreadtrum.com/for_sprd_mozilla/Music_UI_Issue/
  File name : Music_UI.MOV
   username: mouzhi
   password: mouZHI$$61
(Reporter)

Comment 1

4 years ago
Dear Vance -

When music is in scanning mode, and the tiles view once displayed, I can click the search bar go to search mode, but when scanning ended, the search bar will disappears, so cause the UI abnormal, the code related as follows:

// music.js
  update: function tv_update(result) {
    // if no songs in dataSource
    // disable the TabBar to prevent users switch to other page
    TabBar.setDisabled(!this.dataSource.length);

    if (result === null) {
      showCorrectOverlay();
      // Display the TilesView after when finished updating the UI
      document.getElementById('views-tiles').classList.remove('hidden');
      // After the hidden class is removed, hideSearch can be effected
      // because the computed styles are applied to the search elements
      // And ux wants the search bar to retain its position for about
      // a half second, but half second seems to short for notifying users
      // so we use one second instead of a half second
      window.setTimeout(this.hideSearch.bind(this), 1000); // When music scanning ended, hide search bar
      return;
    }

This hide search operation makes the search bar hided, you can see the UI displayed abnormal, I did some modification(workaround) can solved this problem, but I want mozillan's help to find a better way to fix this issue.

My workaround way:

diff --git a/apps/music/js/music.js b/apps/music/js/music.js
index efe0621..9d12de1 100644
--- a/apps/music/js/music.js
+++ b/apps/music/js/music.js
@@ -826,7 +826,6 @@ var TilesView = {
     this.index = 0;
     this.anchor.innerHTML = '';
     this.view.scrollTop = 0;
-    this.hideSearch();
   },
 
   hideSearch: function tv_hideSearch() {
@@ -850,7 +849,6 @@ var TilesView = {
       // And ux wants the search bar to retain its position for about
       // a half second, but half second seems to short for notifying users
       // so we use one second instead of a half second
-      window.setTimeout(this.hideSearch.bind(this), 1000);
       return;
     }
 
@@ -1225,7 +1223,6 @@ var ListView = {
     this.anchor.innerHTML = '';
     this.anchor.style.height = 0;
     this.view.scrollTop = 0;
-    this.hideSearch();
     this.moveTimer = null;
     this.scrollTimer = null;
   }, 

BTW, this issue for SPRD is critical(PTR3 review), please help to find some one have a quick look, and give me some advices.

Really thanks!
Flags: needinfo?(vchen)
Hi Chens -

I upload the reproduce video here:

https://www.youtube.com/watch?v=UrA3IfpRsP8&feature=youtu.be

Could you help to take a look at this bug? SPRD already has a workaround fix but they still prefer to get a official patch from us

Thanks
Flags: needinfo?(vchen) → needinfo?(chens)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8610355 [details] [review]
[gaia] shamenchens:Bug1168256-MusicSearchInTile > mozilla-b2g:v2.1s

Lin Hui, this patch could fix the problem, would you try it and share the result with us?

Dominic, this patch is for 2.1s, would you take a look and give me some feedback? thanks!
Flags: needinfo?(chens) → needinfo?(lin.hui)
Attachment #8610355 - Flags: feedback?(dkuo)
(Reporter)

Comment 5

4 years ago
(In reply to Sherman Chen [:chens] from comment #4)
> Comment on attachment 8610355 [details] [review]
> [gaia] shamenchens:Bug1168256-MusicSearchInTile > mozilla-b2g:v2.1s
> 
> Lin Hui, this patch could fix the problem, would you try it and share the
> result with us?
After applying this patch, issue fixed, thanks you for your great help.

BTW, could you help to landed this modification on 2.1s branch?

Thank you.
Flags: needinfo?(lin.hui)
(Assignee)

Updated

4 years ago
Attachment #8610355 - Flags: feedback?(dkuo) → review?(dkuo)
nominate to 2.1s and ni Steven to follow up on landing patch. 

Chens, Lin Hui, thanks for your help! From the bug submission to the patch ready, it only takes 3 hours!
blocking-b2g: --- → 2.1S+
Flags: needinfo?(styang)
Hi Dominic, do you mind sparing some time to review the patch? many thanks.
Flags: needinfo?(dkuo)
Comment on attachment 8610355 [details] [review]
[gaia] shamenchens:Bug1168256-MusicSearchInTile > mozilla-b2g:v2.1s

Sherman, apologize for the late review. Thanks for working on this, the patch looks good to me, it's trivial and simple though I cannot think of if there are other cases we might encounter when the music is scanning and the user wants to search, anyway, since comment 5 verified this does work it should be good to go.
Flags: needinfo?(dkuo)
Attachment #8610355 - Flags: review?(dkuo) → review+
(Assignee)

Comment 9

4 years ago
2.1s: https://github.com/mozilla-b2g/gaia/commit/e29043077da834854bfda9d409d1e690fb8070c3
Assignee: nobody → chens
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(In reply to Dominic Kuo [:dkuo] from comment #8)
> Comment on attachment 8610355 [details] [review]
> [gaia] shamenchens:Bug1168256-MusicSearchInTile > mozilla-b2g:v2.1s
> 
> Sherman, apologize for the late review. Thanks for working on this, the
> patch looks good to me, it's trivial and simple though I cannot think of if
> there are other cases we might encounter when the music is scanning and the
> user wants to search, anyway, since comment 5 verified this does work it
> should be good to go.

thanks Dominic.
Flags: needinfo?(styang)
This bug has been verified as "pass" on latest v2.1S (512mb) build by the STR in Comment 0.

Actual results: It displays the search box normally.
See attachment: verified_v2.1S(512mb).3gp
Reproduce rate: 0/6


Device: v2.1S_512mb (Verified)
Build ID               20150618001206
Gaia Revision          4196ca9119b4cde8353130165de90c0ffa6060a3
Gaia Date              2015-06-17 03:30:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/8614617a0eb9
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
QA Whiteboard: [MGSEI-Triage+]
Hi Josh,

   This is a major bug, and it is also reproduced on latest Flame 2.0/2.1/2.2, but not repro on master. Could you have a look?  Thanks.


-----------------------------------------------------------------------------------
Actual results (v2.2): After scanning ended, it shows black area which has no any response when you tap on the black area.

See attachment: verify_v2.2.3gp and logcat_v2.2_2109.txt
Reproduce rate: 5/5(v2.2), 3/3(v2.0/2.1), 0/5(v3.0).

-------------------------------------------------------------------------------------
Device: Flame v2.2 build(affected)
Build ID               20150618162503
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/14a1a46b54ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.195202
Firmware Date          Thu Jun 18 19:52:13 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0 build(unaffected)
Build ID               20150618160206
Gaia Revision          55bac3c151bff4f0ce0e8715962c4676fefb0887
Gaia Date              2015-06-18 16:49:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/656ea3bfbb4e
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.192643
Firmware Date          Thu Jun 18 19:26:54 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jocheng)
Hi Chens,
Do you mind also raise 2.2 Uplift request approval?
Thanks!
blocking-b2g: 2.1S+ → 2.2?
Flags: needinfo?(jocheng) → needinfo?(sherman.chens+moz)
(Assignee)

Comment 17

4 years ago
Posted file Pull request to 2.2
Music app had refactor work in v2.2 so we can't simply uplift.

Here's the patch for 2.2, but since I don't have device in hand, could I ask Shelly's verify and Domi's review? thanks!

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: As comment 0, abnormal ui and can't us music app.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): Verified on v2.1s, should be no risk.
[String changes made]: None.
Flags: needinfo?(sherman.chens+moz)
Attachment #8626051 - Flags: review?(dkuo)
Attachment #8626051 - Flags: feedback?(lixia)
Attachment #8626051 - Flags: approval-gaia-v2.2?
Hi Sherman,

    After building the patch of comment 17 into latest Flame v2.2, this bug can't be reproduced anymore. It displays search box correctly and can search songs normally. Thanks.
Flags: needinfo?(sherman.chens+moz)
Flags: needinfo?(sherman.chens+moz)
Flags: needinfo?(sherman.chens+moz)
Attachment #8626051 - Flags: feedback?(lixia) → feedback?
Attachment #8626051 - Flags: feedback? → feedback+

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Flags: needinfo?(sherman.chens+moz)
(Assignee)

Comment 19

4 years ago
I don't see any action for me, clearing my ni.
Comment on attachment 8626051 [details] [review]
Pull request to 2.2

The v2.2 patch is almost the same so carrying on the r+ from the v2.1s patch.
Attachment #8626051 - Flags: review?(dkuo) → review+
Comment on attachment 8626051 [details] [review]
Pull request to 2.2

Thanks Dominic and Chens!
Attachment #8626051 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as "pass" on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: After scanning is ended, it shows search box normally.
See attachment: verified_v2.2.3gp
Reproduce rate: 0/6


Device: Flame v2.2 (Verified) 
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.195343
Firmware Date          Wed Jul  1 19:53:55 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.