[FFOS] Gonk's PDM cannot enter dormant state.

RESOLVED FIXED in Firefox 41

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bwu, Assigned: bwu)

Tracking

({regression})

37 Branch
mozilla41
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
When playing some videos from browser and pushing the home key, PDM doesn't enter dormant and codec is not released.
(Assignee)

Comment 1

3 years ago
User experience impacted: 
If user watch video from browsers and then push the home key to play a video file in video app, video app will show "Another app is currently using the video player".
Keywords: regression
(Assignee)

Comment 2

3 years ago
This should be caused by the Bug 1163458.
The root cause is MOZ_GONK_MEDIACODEC is not defined dom/media, so READER_DORMANT_HEURISTIC will not be defined in [1] and subsequently MediaFormatReader's IsDormantNeeded()[2] returns false. 


[1]https://dxr.mozilla.org/mozilla-central/source/dom/media/MediaFormatReader.h#20
[2]https://dxr.mozilla.org/mozilla-central/source/dom/media/MediaFormatReader.cpp#1288
(Assignee)

Comment 3

3 years ago
Created attachment 8610472 [details] [diff] [review]
Add-the-define-MOZ_GONK_MEDIACODEC-to-dom/media.patch

Root cause:
Per comment 2. 

Solution:
Add the define, MOZ_GONK_MEDIACODEC, to dom/media.
Attachment #8610472 - Flags: review?(cpearce)
Attachment #8610472 - Flags: review?(cpearce) → review+
(Assignee)

Comment 4

3 years ago
Created attachment 8610985 [details] [diff] [review]
Add-the-define-MOZ_GONK_MEDIACODEC-to-dom-media.patch

Thanks for cpearce's review! 
Carry r+ from cpearce.
Attachment #8610472 - Attachment is obsolete: true
Attachment #8610985 - Flags: review+
(Assignee)

Comment 5

3 years ago
Try server: 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=44583ec38e13
(Assignee)

Comment 6

3 years ago
Test results are all green.
Keywords: checkin-needed

Comment 7

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a3a3e00caaff
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/a3a3e00caaff
https://hg.mozilla.org/mozilla-central/rev/a3a3e00caaff
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Depends on: 1173954
You need to log in before you can comment on or make changes to this bug.