Closed Bug 1168377 Opened 5 years ago Closed 4 years ago

Hello shouldn't let you attempt to join a room from different windows

Categories

(Hello (Loop) :: Client, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1241427

People

(Reporter: adalucinet, Unassigned)

Details

Reproducible on Firefox 38.0.5 build 4 (Build ID: 20150525141253)
Affected platforms: Mac OS X 10.9.5, Ubuntu 14.04 32-bit, Windows 7 64-bit and Windows 8.1 x86

Steps to reproduce:
1. Start Firefox.
2. Click on Hello icon and start a conversation.
3. Click on 'Share your screen' button.
4. Select 'Share my tabs'/'Share other Windows'.
5. Send the conversation link to a second PC.
7. Ask the person from the second PC to join the conversation
8. Drag the shared tab from step 4 in a new window.
9. Click on Hello button and select the on going conversation.

Expected result:
Hello icon is green.

Actual result:
Hello icon is blue.

Notes:
1. Browser console output:
"Loop hawkRequest error:" Object { code: 400, errno: 202, error: "The room is full." } MozLoopService.jsm:670
"Error in state `room-joining`:" Object { code: 400, errno: 202, error: "The room is full." } activeRoomStore.js:99:0
2. Also reproducible with 38.0.5 build 3; *NOT* reproducible with Nightly from 2015-02-13: looking into regression range.
The actual issue here is that for some reason, we're letting you attempt to join a room from a different window.

This circumvents various assumptions of our code, at which point various things break like the colouring of the Hello button.

On a technical level, I think our LoopRooms/MozLoopService code only detects an open conversation window within the most active window. Hence, we need to add a bit more in here.
Summary: Hello button turns blue while screensharing is active → Hello shouldn't let you attempt to join a room from different windows
Regression range:
(m-c)
Last good revision: 0189941a3fd5
First bad revision: 43fb1f92e8d4
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0189941a3fd5&tochange=43fb1f92e8d4

(m-i)
Last good revision: 1e4b76918021
First bad revision: 43fb1f92e8d4
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1e4b76918021&tochange=43fb1f92e8d4
Rank: 45
Flags: firefox-backlog+
Priority: -- → P4
Whiteboard: [bug]
Whiteboard: [bug] → [bug][triage]
Whiteboard: [bug][triage] → [triage]
Pretty much the same cause as bug 1241427 - going to dupe forward as I think that bug is slightly clearer as to what we need to do.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1241427
Whiteboard: [triage]
You need to log in before you can comment on or make changes to this bug.