Closed Bug 1168448 Opened 5 years ago Closed 5 years ago

test_homescreen_column_layout.py: "TypeError: int() argument must be a string or a number, not 'NoneType'"

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: onelson, Assigned: martijn.martijn)

References

()

Details

Attachments

(1 file)

Description:
test_homescreen_column_layout is encountered a common exception near the end of it's test after switching the column layout from 4 to 3. On checking to verify if the value of attribute 'cols' is equal to "4", the test fails in interpreting the value. The behavior that is being tested here is not failing, rather the method in which the value is checked.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/60/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/57/

Repro Steps:
1) Update phone to 20150526010203
2) Open the Settings app
3) Navigate to 'Homescreen Settings'
4) Change the value of "Homescreen Columns" from 'Three' to 'Four'
5) Observe homescreen and column layout

Results
Homescreen Column layout changes to 4


Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_column_layout.py", line 36, in test_homescreen_column_layout
Wait(self.marionette).until(lambda m: initial_number_of_columns != self.homescreen.number_of_columns)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/wait.py", line 122, in until
rv = condition(self.marionette)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_column_layout.py", line 36, in <lambda>
Wait(self.marionette).until(lambda m: initial_number_of_columns != self.homescreen.number_of_columns)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/app.py", line 164, in number_of_columns
return int(self.marionette.find_element(*self._landing_page_locator).get_attribute('cols'))
TypeError: int() argument must be a string or a number, not 'NoneType'


Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	26 May 2015 08:28:57
Device firmware (incremental) 	eng.cltbld.20150526.042846
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	f0484102
Device uptime 	0 days 0 hours 2 minutes 2 seconds
Gaia date 	25 May 2015 17:47:20
Gaia revision 	7cd4130d4f98
Gecko build 	20150526010203
Gecko revision 	43f2f0c506ea
Gecko version 	41.0a1


Reproducible manually: NO

Repro frequency: 2/6
* did not reproduce this issue via local automated tests: 5/5 passing
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Assignee: nobody → martijn.martijn
Comment on attachment 8610849 [details] [review]
[gaia] mwargers:1168448 > mozilla-b2g:master

I could reproduce this one time on my device (the first time I tried). Afterwards, I couldn't reproduce it anymore.
Anyway, this would fix it.
Attachment #8610849 - Flags: review?(npark)
Attachment #8610849 - Flags: review?(jlorenzo)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Comment on attachment 8610849 [details] [review]
[gaia] mwargers:1168448 > mozilla-b2g:master

Looks great!
Attachment #8610849 - Flags: review?(jlorenzo) → review+
Comment on attachment 8610849 [details] [review]
[gaia] mwargers:1168448 > mozilla-b2g:master

looks good to me
Attachment #8610849 - Flags: review?(npark) → review+
https://github.com/mozilla-b2g/gaia/commit/677f20f0614d8e690ac3ac136cc3e92a97cf2a55
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.