Closed Bug 1168467 Opened 6 years ago Closed 5 years ago

Tanx game suffers from low framerate spikes

Categories

(Core :: Canvas: WebGL, defect)

x86_64
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ssimon, Unassigned)

References

()

Details

(Whiteboard: [betabreakers-fx40][gfx-noted])

Attachments

(2 files)

Attached file ff40_onyxia_DxDiag.txt
Actual Results:
While playing the Tanx game, occasionally the framerate will drop to unplayable levels.  It seems to be very inconsistent.

Expected Results:
Tanx game should maintain a playable framerate.

Steps to Recreate:
1 Navigate to the Tanx game using Firefox
2 Play the game for a few minutes
3 Notice the framerate spike randomly during gameplay

NOTE: In chrome, the game does not fully render.  The minimap is visible, and play names can be seen, but the background, tanks and everything else on screen does not render / is not viewable.  Tried with e10s togged on and off, did not seem to make a difference.
Whiteboard: [betabreakers-fx40]
It would be very useful if you could collect a performance profile of the game while the issue is occurring. There are instructions here: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Profiling_with_the_Built-in_Profiler
The game runs very smoothly for me but I have a different configuration.
Whiteboard: [betabreakers-fx40] → [betabreakers-fx40][gfx-noted]
(In reply to Nicolas Silva [:nical] from comment #2)
> It would be very useful if you could collect a performance profile of the
> game while the issue is occurring. There are instructions here:
> https://developer.mozilla.org/en-US/docs/Mozilla/Performance/
> Profiling_with_the_Built-in_Profiler
> The game runs very smoothly for me but I have a different configuration.

Unfortunately, after recording performance, when I click "Stop Recording" the browser crashes.  Before it crashed, I could see that the framerate dropped as low as 2.8 fps.

I attempted to record performance twice, and it crashed twice.

Here are the two crash reports: 

https://crash-stats.mozilla.com/report/index/67007cef-12f3-451e-8ca2-3d53a2150528
https://crash-stats.mozilla.com/report/index/e2854987-35e3-4d2c-98e4-b85de2150528
(In reply to ssimon from comment #3)
> https://crash-stats.mozilla.com/report/index/67007cef-12f3-451e-8ca2-
> 3d53a2150528
> https://crash-stats.mozilla.com/report/index/e2854987-35e3-4d2c-98e4-
> b85de2150528

These are both OOM crashes, specifically bug 1132499.
Depends on: 1132499
Bug no longer occurs. Game is completely playable no performance issues.
Note: Browser 43 was used to try to replicate
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.