Closed Bug 1168863 Opened 5 years ago Closed 2 years ago

Menu images stop displaying in GMail

Categories

(Core :: ImageLib, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1380649

People

(Reporter: lmandel, Unassigned)

Details

(Whiteboard: [gfx-noted] [platform-rel-Google] [platform-rel-Gmail])

Attachments

(2 files)

Menu images stop being displayed in GMail after some period of time. (This may occur on other sites as well but it is noticeable in GMail.) Reloading the tab restores the images. This is quite irritating for menu images as this requires the user to hover over a grey box for alt help.

STR:
1. Open GMail and user for some period of time. Notice that some of the icons for archive, refresh, delete, etc. are no longer shown.

Expected:
All images will continue to be displayed as long as I'm on this site.

Actual:
Some of the images/icons for archive, refresh, delete, etc. (changes each time) are no longer shown.
I'm currently using 38.0.5b2 but I've noticed this on and off for a while. Was hoping that one of the ImageLib fixes in 38.0.1 had fixed this issue but the issue persists.
Seth - Any ideas as to cause and where to start debugging? How can I get you more information or try to force my browser into this state?
Flags: needinfo?(seth)
Whiteboard: [gfx-noted]
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #2)
> Seth - Any ideas as to cause and where to start debugging? How can I get you
> more information or try to force my browser into this state?

I'm not sure how to force your browser into this state, because I'm not sure what's causing this. But if you do manage to reproduce again, please open a new window (not a new tab, because opening a new tab will change the state of other tabs in the same window) and capture a report in about:memory using the new window.

about:memory reports have a lot of useful information about the current state of images and textures in the browser; they're usually the first thing I check.
Flags: needinfo?(seth)
I was able to reproduce the issue and capture a memory report today, which I have sent privately to Seth because it contains a list of my open tabs.
Whiteboard: [gfx-noted] → [gfx-noted] [platform-rel-Google] [platform-rel-Gmail]
platform-rel: --- → ?
platform-rel: ? → ---
Since more than 2 months i'm facing the same issue.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380649
You need to log in before you can comment on or make changes to this bug.