test_system_notification_bar.py: "ElementNotVisibleException: Element is not currently visible and may not be manipulated"

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: onelson, Assigned: martijn.martijn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
test_system_notification_bar failed all observed tests run today by a ElementNotVisibleException. This appears to have been broken by the fix for bug 1164073

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/62/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/58/HTML_Report/

Repro Steps:
1) Update phone to 20150527010201
2) Open Utility Tray, clear notifications
3) Close Utility Tray, generate notification
4) Open Utility Tray

Actual:
Utility Tray does not open

Expected: 
Utility Tray opens, clears notifications


Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_system_notification_bar.py", line 41, in test_notification_bar
utility_tray.clear_all_notifications()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/system/regions/utility_tray.py", line 39, in clear_all_notifications
self.marionette.find_element(*self._notification_clear_locator).tap()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/marionette.py", line 80, in tap
return self.marionette._send_message('singleTap', 'ok', id=self.id, x=x, y=y)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/marionette.py", line 711, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/marionette.py", line 747, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
ElementNotVisibleException: ElementNotVisibleException: Element is not currently visible and may not be manipulated


Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	27 May 2015 08:42:14
Device firmware (incremental) 	eng.cltbld.20150527.044203
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	1d9e570a
Device uptime 	0 days 0 hours 2 minutes 4 seconds
Gaia date 	26 May 2015 19:31:37
Gaia revision 	8ca93673869a
Gecko build 	20150527010201
Gecko revision 	ff2e07228041
Gecko version 	41.0a1


Reproducible manually: NO

Repro frequency: 6/6
(Reporter)

Updated

3 years ago
Blocks: 1164073
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
(Assignee)

Updated

3 years ago
Assignee: nobody → martijn.martijn
(Assignee)

Comment 1

3 years ago
Sorry, this was due to a bad copy-paste I used from the pull request from bug 1164073:
https://github.com/mozilla-b2g/gaia/commit/2db8fd24a2fa2763b00f385d1425b96acda7d5c8#diff-fad4a3a01385cf33a2f57a9275b0f05b

I only tested on b2g desktop, where it passed. I'll fix it now.
Created attachment 8611286 [details] [review]
[gaia] mwargers:1168876 > mozilla-b2g:master
(Assignee)

Comment 3

3 years ago
Comment on attachment 8611286 [details] [review]
[gaia] mwargers:1168876 > mozilla-b2g:master

Again, sorry for causing this.
I now checked that this works locally on my device.
Attachment #8611286 - Flags: review?(npark)
Attachment #8611286 - Flags: review?(jlorenzo)
Comment on attachment 8611286 [details] [review]
[gaia] mwargers:1168876 > mozilla-b2g:master

I also should have ran it on device with a large code change like Bug 1164073.
Attachment #8611286 - Flags: review?(npark) → review+
Comment on attachment 8611286 [details] [review]
[gaia] mwargers:1168876 > mozilla-b2g:master

r+ with the nits on the comments
Attachment #8611286 - Flags: review?(jlorenzo) → review+
(Assignee)

Comment 6

3 years ago
Ok, updated patch. I'll check it in as soon as Treeherder Try is green.
(Assignee)

Comment 7

3 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/876ec31b51b53fa0e0676363896202f7835fd88b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.