[DOGFOOD] Phonebook -- top frame contents get truncated.

VERIFIED DUPLICATE of bug 11577

Status

()

P3
normal
VERIFIED DUPLICATE of bug 11577
20 years ago
20 years ago

People

(Reporter: sfraser_bugs, Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Go to http://phonebook/ in apprunner (Netscape internal). Note that the top
frame fails to render at all, and is not even erased to white.

Updated

20 years ago
Assignee: karnaze → pollmann

Comment 1

20 years ago
Reassigning to Eric.

Updated

20 years ago
Assignee: pollmann → harishd
Component: HTMLFrames → Parser
OS: Mac System 8.5 → All
Summary: [DOGFOOD] Phonebook -- top frame fails to render. → [DOGFOOD] Phonebook -- top frame contents get truncated.

Comment 2

20 years ago
This happens regardless of if the frame is in a frameset or not.

The top frame of the phonebook CGI (see URL above) is blank when loaded.  I
dumped the content model and it is:

html refcount=3<
  head refcount=2<
    Comment refcount=2<<!--\n | $Id: phone.html,v 1.7 1998/06/18 21:09:06 rperez
Exp $\n |\n | AUTHOR: Rob Perez <rperez@netscape.com>\n |\n | SYNOPSIS:\n |
Top frame containing the search form.\n |\n | HISTORY:\n |   20-Feb-1999   RAF
Updated to DSGW 4.0 specs\n |   10-Oct-1997   Rob   Added height and width tags
on Phone image.\n |\n
+-------------------------------------------------------------------------- -->>
    title refcount=2<
      Text refcount=2<AOL Telephone Book>
    >
  >
  body refcount=3<
    Text refcount=3<\n\n\n\n\n>
    script language=JAVASCRIPT src=../html-pb/phone.js refcount=3<
      Text refcount=2<\n>
    >
  >
>

Then I reloaded the page and everything appeared correctly.
Reloaded and the contents were truncated as above...
It alternates back and forth between truncating and not truncating every time.

The other weirdness is that the HTML of the page looks like this:

<HTML>
 <HEAD>
  <TITLE>
  <SCRIPT LANGUAGE=JAVASCRIPT SRC="../html-pb/phone.js">
  </SCRIPT>
 </HEAD>
 <BODY>...

But when the page isn't loaded, the content model it appears as:

<HTML>
 <HEAD>
  <TITLE>
 </HEAD>
 <BODY>
  <SCRIPT LANGUAGE=JAVASCRIPT SRC="../html-pb/phone.js">
  </SCRIPT>
 </BODY>
</HTML>

Somehow the script is getting pushed down into the body. Strange, eh?
Giving this one to Harish to look at...
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 11577 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
verified dup
You need to log in before you can comment on or make changes to this bug.