[Settings] It shows a blank area instead of the timezone when manually select a city located in the current timezone

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: arthurcc, Assigned: gasolin@mozilla.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:+, b2g-master verified)

Details

Attachments

(3 attachments)

STR:

1.Insert a SIM card.
2.Go to Settings->Date & Time.
3.Disable "Set Automatically", select a city that is in your timezone.
4.Enable "Set Automatically".

Actual: It shows a blank area instead of the current timezone

Expected: It shows correct timezone
tracking-b2g: --- → +
Assignee: crh0716 → nobody
Hi Reporter,

    This bug can't be repro on latest build of Flame KK 2.2/2.5 and Aires KK 2.5 by the STR in comment 0. Can we change the status to "workforme"? Thanks.


Actual results: It shows correct timezone.
See attachment: FlameKK_v2.5.3gp
Reproduce rate: 0/10

----------------------------------------------------------------------------------
Device: Flame KK 2.2 (Pass) 
Build ID               20150909032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/96170c571381
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.065103
Firmware Date          Wed Sep  9 06:51:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Pass)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185733
Firmware Date          Wed Sep  9 18:57:43 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150909215153
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.211310
Firmware Date          Wed Sep  9 21:13:17 UTC 2015
Bootloader             s1
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(crh0716)
See Also: → bug 1208807
(Assignee)

Comment 3

3 years ago
I can reproduce it with carriers supporting auto time zone update (NITZ)
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: needinfo?(crh0716)
See Also: → bug 1162276
Created attachment 8673494 [details] [review]
[gaia] gasolin:issue-1169154 > mozilla-b2g:master
(Assignee)

Comment 5

3 years ago
Comment on attachment 8673494 [details] [review]
[gaia] gasolin:issue-1169154 > mozilla-b2g:master

The issue is caused when the automatic timezone is the same as user specified timezone. The timezone change event is not triggered because its not changed.
Therefore we have to force update the string when autoswitch state is changed.
Attachment #8673494 - Flags: review?(yzenevich)
Comment on attachment 8673494 [details] [review]
[gaia] gasolin:issue-1169154 > mozilla-b2g:master

Code looks good. Ideally, it'd be nice to have a unit test for checking that _boundSetTimezoneInfo is called. Otherwise looks good.
Attachment #8673494 - Flags: review?(yzenevich) → review+
(Assignee)

Comment 7

3 years ago
Sorry I should add test for this but let's not block others work described on bug 1208807 comment 12
Will file a followup to add test coverage for datatime panel

merged https://github.com/mozilla-b2g/gaia/commit/20809a0d85bc55bfec8737aeb7cd0dfc92344ec7
Blocks: 1208807
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
See Also: → bug 1215045
Created attachment 8677893 [details]
verified_Aries KK_v2.5.3gp

This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.
                                                                                                       Actual results: After disabling "Set Automatically" and selecting a "Region" & "City" at Date & Time, then enabling "Set Automatically", it shows correct timezone (e.g. Asia/Chongqing or UTC+08:00)
                                                                                                                         See attachment: verified_Aries KK_v2.5.3gp.
Reproduce rate: 0/10


Device: Flame KK 2.5 (pass)
Build ID               20151022150207
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151022.185000
Firmware Date          Thu Oct 22 18:50:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (pass)
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015                                                                                                  Bootloader             s1
status-b2g-master: --- → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.