Closed Bug 1169167 Opened 4 years ago Closed 4 years ago

AsmJS Baseline Compiler

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1232205

People

(Reporter: bbouvier, Unassigned)

References

(Blocks 1 open bug)

Details

First compilation of asm.js modules can take some time, especially on phones and/or for big codebases. As a user, I don't want to have to wait too much the first time before being able to play / use the program. The idea of an asm.js baseline compiler would be to quickly compile a asm.js module while the bigger Odin compilation is made in the background; and switch from the quickly compiled module to the odin module when there are no asm.js activations on the stack.
Does this mean that Odin would have to support OSR?
In the simplest incarnation, the swap would happen only when there were no activations on the stack (which currently happens once a frame).  (Also to be clear, this would be a custom asm.js baseline compiler, not reusing the existing baseline JS compiler.)  With bug 709490, workers may never have to return to the main thread, so we may need to cut over at the level of function calls (by having a uniform (native) call ABI and then patching baseline to optimized).
Blocks: 1191061
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232205
You need to log in before you can comment on or make changes to this bug.