If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[gtk3] White text on grey background on notification toolbar.

RESOLVED FIXED in Firefox 41

Status

()

Core
Widget: Gtk
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: glandium, Assigned: Martin Stránský)

Tracking

unspecified
mozilla41
Points:
---

Firefox Tracking Flags

(e10sm8+, firefox41 fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8612237 [details]
Screenshot.png

I assume this is true for other info bars, although it doesn't happen for the telemetry thing.

See attached screenshot.
(Reporter)

Comment 1

2 years ago
This is the CSS fragment corresponding to the style of those infobars:

http://hg.mozilla.org/mozilla-central/file/baa9c64fea6f/toolkit/themes/linux/global/notification.css#l7

So InfoText must be wrong.
(Assignee)

Comment 2

2 years ago
1011     gtk_style_context_add_class(style, GTK_STYLE_CLASS_TOOLTIP);
1012     gtk_style_context_get_background_color(style, GTK_STATE_FLAG_NORMAL, &color);
1013     sInfoBackground = GDK_RGBA_TO_NS_RGBA(color);
1014     gtk_style_context_get_color(style, GTK_STATE_FLAG_NORMAL, &color);
1015     sInfoText = GDK_RGBA_TO_NS_RGBA(color);
1016     g_object_unref(style);

Updated

2 years ago
tracking-e10s: --- → m8+
Keywords: polish
(Assignee)

Comment 3

2 years ago
IMHO it should also use tooltip background (which is black) or choose a different text color.
(Assignee)

Comment 4

2 years ago
Actually the bug is caused by transparent tooltip background color which is defined by Gtk3 themes.
(Assignee)

Comment 5

2 years ago
Created attachment 8613482 [details] [diff] [review]
tooltip-background.patch
Assignee: nobody → stransky
Attachment #8613482 - Flags: review?(karlt)
(Assignee)

Comment 6

2 years ago
Unfortunately it breaks all kind of notifications like addon updates and so.
Summary: [gtk3] White text on grey background for e10s post activation info bar. → [gtk3] White text on grey background on notification toolbar.
Attachment #8613482 - Flags: review?(karlt) → review+
(Assignee)

Comment 7

2 years ago
Try build: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8012d33b7c71
(Assignee)

Updated

2 years ago
Keywords: polish → checkin-needed

Comment 8

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/92c770d9b2cc
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/92c770d9b2cc
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.