Closed Bug 1169260 Opened 9 years ago Closed 5 years ago

Missing special characters (due to font) on SUMO

Categories

(support.mozilla.org :: General, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dipster625, Unassigned)

References

Details

Attachments

(3 files)

Attached image screen.jpg
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

Found some missing characters on Slovenian SUMO web page https://support.mozilla.org/sl/get-involved/questions
1 REŠENA TEŽAVA POMAGA VSAK .......
I think the font Komikax doesn't support sl special characters, system kicked in as a backup there..
Yiks i missed font in the above comment.

The system font kicked in as a backup there..
We shouldn't be using fonts that don't have enough character coverage for the locales we support. We should either get a  better version of Komikax, or switch to a font that has full coverage.
Status: UNCONFIRMED → NEW
Ever confirmed: true
FYi, it's not just Slovenian, I check a few other languages (Azerbaijani, Czech, Turkish, etc.) and it also appears broken.
Summary: Missing special characters → Missing special characters (due to font) on SUMO
Seems good to me now. FIXED/WFM?
Is this working correctly for you @mikkCZ .? There hasn't be
Flags: needinfo?(mstanke)
Attached image screenshot 16-01-03.jpg
It's not broken, but there is completely different font shown to me than on the first screenshot when reported.
Flags: needinfo?(mstanke)
Still not working for me on the pl version
OK. I have tried to find a replacement, but didn't found any similar font to replace Komikax. Do you have any preference, what can we use, or just replace it with Open Sans?
Priority: -- → P4
A related issue, maybe deserving it's own bug, but for what I can tell current Open Sans font file does not support entities like ­ (soft hyphen). And Open Sans generally does support them so this issue is specific to how it's used on SUMO.
Some examples of fonts that support the soft hyphen: http://www.fileformat.info/info/unicode/char/ad/fontsupport.htm

At this stage, I am more than fine with anything that looks decent AND supports all the different locales we have to replace Komikax.

The alternative is to make that part of the page an image, and then work with localizers to get those images made in their preferred font.
Um, it may have been that I was looking at a string that wasn't packed enough to actually need that break. Sorry for the noise.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.