If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Mac] Strange animation displayed for the menu button after dismissing the Pocket panel displayed by the tour

RESOLVED WONTFIX

Status

()

Firefox
Tours
P5
normal
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: avaida, Unassigned)

Tracking

({regression})

38 Branch
All
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38.0.5 affected)

Details

Reproducible on:
RC 38.0.5-build4 (20150525141253)

Affected platforms:
Mac OS X 10.9.5

Steps to reproduce:
1. Install either the de, ja-JP-mac, es-ES or ru locales.
2. Launch Firefox.
3. Go to about:config and set browser.uitour.testingOrigins to https://www-demo2.allizom.org.
4. Go to https://www-demo2.allizom.org/en-US/firefox/38.0.5/whatsnew/.
5. Right-click the Pocket button from the toolbar and select to move it to the menu.
6. Click the button from the demo page.
7. Dismiss the panel displayed by the Pocket button by clicking anywhere on the page. Pay attention to the menu button.

Expected result:
The Pocket panel is successfully dismissed, without any UI issues or glitches.

Actual result:
Dismissing the Pocket panel causes a strange blue animation to show up on top of the menu button.

Notes:
* This issue is reproducible with all the locales mentioned, but NOT with en-US.
* Happens ONLY on Mac OS X and ONLY if the Pocket button is placed inside the menu.
* This might be a regression caused by Bug 1161810.
> * This issue is reproducible with all the locales mentioned, but NOT with en-US.

Fwiw, I see this little oddity on en-US build too.
I also see it in on en-US. This is pretty minor, and seems unlikely to cause any problems with users.
Priority: -- → P5
The pocket pages have been decommissioned along with the related UITour functionality. Closing this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.