Closed Bug 1169292 Opened 6 years ago Closed 6 years ago

Flame: Black area is shown while scrolling in Calendar Day view

Categories

(Core :: Layout, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: njpark, Unassigned)

References

Details

(Keywords: regression, Whiteboard: fbimage)

Attachments

(2 files)

STR:
Open Calendar app
Scroll back & forth in day view
Change to week view, scroll left & right, then up & down
Change to day view, scroll left & right, then up & down.

Expected;
Views are displayed normally.
Actual:
At the top below the header, a black area appears while scrolling up & down.  It looks as if the area is not being drawn, because sometimes I see the desktop background through it



Version Info:
Build ID               20150528010203
Gaia Revision          05380df3158fa39e1dde1687c0bf11a71f8c6868
Gaia Date              2015-05-27 06:27:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/baa9c64fea6f
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.044033
Firmware Date          Thu May 28 04:40:44 EDT 2015
Bootloader             L1TC000118D0
ni?ing :kat since this looks like a graphics regression shown in Calendar that came back, and at the time I was talking to him.  Do you think it's a layer bug?
Flags: needinfo?(bugmail.mozilla)
Whiteboard: fbimage
It's not clear from your description if it's a graphics or layout issue; there could be a number of different root causes. If it's reproducible getting a regression window would be useful.
Flags: needinfo?(bugmail.mozilla)
[Blocking Requested - why for this release]:
Visible regression.

Window already requested.
blocking-b2g: --- → 3.0?
Keywords: qawantedregression
QA Contact: ktucker
I flashed to the reporter's build and was unable to reproduce this issue after several attempts.

I followed the steps in Comment 0 but no graphical anomalies were observed in day view. 

Environmental Variables:
Device: Flame 3.0 (Shallow Flash)(KK)(319mb)
BuildID: 20150527152416
Gaia: 05380df3158fa39e1dde1687c0bf11a71f8c6868
Gecko: 2c815cc65cc9
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1

Leaving the regressionwindow-wanted keyword for someone else to try.
QA Contact: ktucker
Attached image screenshot of issue
I was able to repro it on today's 3.0. I'm attaching a screenshot because it's not apparent on it of the issue. The repro rate varies from 1/~10 to 1/~50 scrolls; it should happen within 1 minute of scrolling.

Device: Flame (KK, 319MB, full flashed)
BuildID: 20150528010203
Gaia: 05380df3158fa39e1dde1687c0bf11a71f8c6868
Gecko: baa9c64fea6f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

--------

Flame 2.2 seems unaffected. Scrolled for about 2 minutes without seeing graphical issues.

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150528002504
Gaia: 999bc627063d16c20f703e702f31a5cf0da8b4a6
Gecko: 351101ec82ba
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----

I won't be too hopeful in finding the regression window for this one due to low repro rate, but I'll try and see what I can come up with.
QA Contact: pcheng
> I'm attaching a screenshot because it's not apparent on it of the issue

I meant to say the issue is not apparent on the original screenshot so I attached another one that shows it.
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150526123813
Gaia: 0d67eb545b2f4342525d14e1a10e80c91c87ada0
Gecko: d551aa12ebb1
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150526130714
Gaia: 0d67eb545b2f4342525d14e1a10e80c91c87ada0
Gecko: 507b6aba4555
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d551aa12ebb1&tochange=507b6aba4555

Caused by patches for Bug 1148582.
Blocks: 1148582
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
David, can you take a look at this please? Looks like the work done on bug 1148582 might be the culprit here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dvander)
This sounds a lot like bug 1062792.
A fixed bug, so perhaps we need to refix it similarly.
If you leave the screen on, the black area actually flickers once in a while and displays a portion of the calendar view.
Changing component based on comment 10.
Component: Gaia::Calendar → Layout
Product: Firefox OS → Core
Patrick, Can you please check if this bug is fixed?

Thanks
Flags: needinfo?(pbylenga)
QAWanted to see if this is still occurring.
Flags: needinfo?(pbylenga)
Keywords: qawanted
This issue is no longer occurring on Flame 2.5 and Aries 2.5. No black artifacts appear when scrolling in Calendar.

Device: Flame 2.5
BuildID: 20150814030213
Gaia: 39b121515ab8a8c3ea07f26d3ba1dd792e90217c
Gecko: 4e883591bb5dff021c108d3e30198a99547eed1e
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150814042814
Gaia: 39b121515ab8a8c3ea07f26d3ba1dd792e90217c
Gecko: 4e883591bb5dff021c108d3e30198a99547eed1e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Status: NEW → RESOLVED
blocking-b2g: 2.5? → ---
Closed: 6 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.