Launching WebMaker crashes.

RESOLVED DUPLICATE of bug 1168221

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1168221
2 years ago
2 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({dogfood})

unspecified
ARM
Gonk (Firefox OS)
dogfood

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [spark], crash signature)

1. download build from : https://tools.taskcluster.net/task-inspector/#xRVy3KtOQdKKP1gu0quJIw/0
2. launch webmaker

Expected: webmaker launches
Actual: crash

Crash id : bp-03e0208f-9adf-4d73-8e65-b76fb2150529

 0 	libxul.so 	mozilla::net::WebSocketChannel::StopSession(nsresult) 	/home/worker/workspace/gecko/netwerk/protocol/websocket/WebSocketChannel.cpp:2232
1 	libxul.so 	mozilla::net::WebSocketChannel::Close(unsigned short, nsACString_internal const&) 	/home/worker/workspace/gecko/netwerk/protocol/websocket/WebSocketChannel.cpp:3253
2 	libxul.so 	mozilla::net::WebSocketChannelParent::RecvClose(unsigned short const&, nsCString const&) 	/home/worker/workspace/gecko/netwerk/protocol/websocket/WebSocketChannelParent.cpp:161
3 	libxul.so 	mozilla::net::PWebSocketParent::OnMessageReceived(IPC::Message const&) 	/home/worker/workspace/B2G/objdir-gecko/ipc/ipdl/PWebSocketParent.cpp:386
4 	libxul.so 	mozilla::dom::PContentParent::OnMessageReceived(IPC::Message const&) 	/home/worker/workspace/B2G/objdir-gecko/ipc/ipdl/PContentParent.cpp:3238
5 	libxul.so 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) 	/home/worker/workspace/gecko/ipc/glue/MessageChannel.cpp:1279
6 	libxul.so 	mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message const&) 	/home/worker/workspace/gecko/ipc/glue/MessageChannel.cpp:1198
7 	libxul.so 	mozilla::ipc::MessageChannel::OnMaybeDequeueOne() 	/home/worker/workspace/gecko/ipc/glue/MessageChannel.cpp:1182
8 	libxul.so 	RunnableMethod<FdWatcher, void (FdWatcher::*)(), Tuple0>::Run() 	/home/worker/workspace/gecko/ipc/chromium/src/base/tuple.h:383
9 	libxul.so 	mozilla::ipc::MessageChannel::DequeueTask::Run() 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/ipc/MessageChannel.h:446
10 	libxul.so 	MessageLoop::RunTask(Task*) 	/home/worker/workspace/gecko/ipc/chromium/src/base/message_loop.cc:361
11 	libxul.so 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) 	/home/worker/workspace/gecko/ipc/chromium/src/base/message_loop.cc:369
12 	libxul.so 	MessageLoop::DoWork() 	/home/worker/workspace/gecko/ipc/chromium/src/base/message_loop.cc:456
13 	libxul.so 	mozilla::ipc::DoWorkRunnable::Run() 	/home/worker/workspace/gecko/ipc/glue/MessagePump.cpp:220
14 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	/home/worker/workspace/gecko/xpcom/threads/nsThread.cpp:846
15 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	/home/worker/workspace/gecko/xpcom/glue/nsThreadUtils.cpp:265
16 	libxul.so 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	/home/worker/workspace/gecko/ipc/glue/MessagePump.cpp:127
17 	libxul.so 	MessageLoop::RunInternal() 	/home/worker/workspace/gecko/ipc/chromium/src/base/message_loop.cc:233
18 	libxul.so 	MessageLoop::Run() 	/home/worker/workspace/gecko/ipc/chromium/src/base/message_loop.cc:226
19 	libxul.so 	nsBaseAppShell::Run() 	/home/worker/workspace/gecko/widget/nsBaseAppShell.cpp:165
20 	libxul.so 	nsAppStartup::Run() 	/home/worker/workspace/gecko/toolkit/components/startup/nsAppStartup.cpp:280
21 	libxul.so 	XREMain::XRE_mainRun() 	/home/worker/workspace/gecko/toolkit/xre/nsAppRunner.cpp:4244
22 	libxul.so 	XREMain::XRE_main(int, char**, nsXREAppData const*) 	/home/worker/workspace/gecko/toolkit/xre/nsAppRunner.cpp:4328
23 	libxul.so 	XRE_main 	/home/worker/workspace/gecko/toolkit/xre/nsAppRunner.cpp:4417
24 	b2g 	do_main 	/home/worker/workspace/gecko/b2g/app/nsBrowserApp.cpp:167
25 	b2g 	b2g_main(int, char const**) 	/home/worker/workspace/gecko/b2g/app/nsBrowserApp.cpp:299
26 	b2g 	main 	/home/worker/workspace/gecko/b2g/app/B2GLoader.cpp:232
27 	libc.so 	__libc_init 	/home/worker/workspace/B2G/bionic/libc/bionic/libc_init_dynamic.cpp:112
28 	b2g 	b2g@0xc1ca 	
29 	linker 	set_soinfo_pool_protection 	/home/worker/workspace/B2G/bionic/linker/linker.cpp:291
30 		@0xbea03a69
Crash Signature: [@ mozilla::net::WebSocketChannel::StopSession(nsresult) ]
Depends on: 1168221
[Blocking Requested - why for this release]:
blocking-b2g: --- → spark?
No longer depends on: 1168221
Flags: needinfo?(drs)
Whiteboard: [spark]

Comment 2

2 years ago
Given the signature, this may be a dupe of bug 1168221, actually. Naoki, it would be cool if you could test if this works again once a build with the patch from there is available.
Keywords: dogfood
blocking-b2g: spark? → spark+
Flags: needinfo?(drs) → needinfo?(nhirata.bugzilla)
I reproduced this a few days ago, but cannot reproduce w/ latest OTA update (build ID 20150603164854).

So I think comment 2 is correct. Duping.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1168221
(Canceling needinfo, as I think comment 3 answers it.)
Flags: needinfo?(nhirata.bugzilla)

Updated

2 years ago
Component: Gaia::Foxfooding → Gaia
blocking-b2g: spark+ → 2.5+
You need to log in before you can comment on or make changes to this bug.