Closed Bug 1169494 Opened 7 years ago Closed 7 years ago

[youtube] some video titles appear cutoff on video list view

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED INVALID
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: pcheng, Unassigned)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe])

Attachments

(2 files)

Attached image screenshot of issue
Description:
On youtube app or on browser and go to youtube.com, some video title text appear cutoff on the right on the video list view.

STR:
1) Open browser and go to youtube.com (or use youtube app)
2) On youtube's search field, search for 'minecraft'
3) Observe the search result page

Expected: Text appears correctly. If it's too long it should be truncated correctly.

Actual: Some video titles are cutoff on the right. See screenshot.

Device: Flame (full flashed 319MB KK)
BuildID: 20150528010203
Gaia: 05380df3158fa39e1dde1687c0bf11a71f8c6868
Gecko: baa9c64fea6f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
I'd been tied up doing another task. This affects 2.2 as well. Will do the rest of branch checking tomorrow. NI myself.

Device: Flame 2.2
BuildID: 20150528002504
Gaia: 999bc627063d16c20f703e702f31a5cf0da8b4a6
Gecko: 351101ec82ba
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(pcheng)
Whiteboard: [3.0-Daily-Testing], [systemsfe]
This issue is not a regression and occurs on all branches on Flame including v18D-1 base image only.

Device: Flame 2.1
BuildID: 20150529001200
Gaia: 2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gecko: 894528758073
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150529000202
Gaia: 5552bf529d3d6775a968942e9afa6c1d4037362c
Gecko: 239793ea749a
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pcheng) → needinfo?(ktucker)
pinging djf for insight.  Do you think it's a tech evangelism bug since it's been around for a while?
Flags: needinfo?(dflanagan)
I've never worked on the browser app, so I don't have any particular insight into this. I'd try visiting youtube.com in Firefox for Android. If you get the same result, then it is probably a youtube bug. You could also try a desktop browser in responsive mode with a small screen size, I suppose.

If you can only see this truncation in FirefoxOS, then maybe someone on the SystemsFE team can take a look and see if it is a bug int he FirefoxOS browser app.
Flags: needinfo?(dflanagan)
Aaron, does this bug exist in Android or IOS as well?
Flags: needinfo?(aaron.train)
(In reply to No-Jun Park [:njpark] from comment #5)
> Aaron, does this bug exist in Android or IOS as well?

Teo can check on Android. iOS -> WebKit
Flags: needinfo?(aaron.train) → needinfo?(teodora.vermesan)
Tested with:
Device: Alcatel One Touch (Android 4.1.2)
Browsers: left Chrome and right latest Nightly
Flags: needinfo?(teodora.vermesan)
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
Based on the screenshot from Comment 7, reassigning it to tech evangelism bug
Since this also affects Chrome Mobile, it appears to be just a design decision--not really a compat issue.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.