Closed Bug 1169562 Opened 7 years ago Closed 7 years ago

Simultaneous edit warnings?

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1155839

People

(Reporter: gerv, Unassigned)

Details

This is what I think happened.

I edited
https://wiki.mozilla.org/Workweek_Gaming
to move a line inserted by rmilewski, and clicked "Submit".

Later, I came back and realised I had to click Submit again, because it was warning me about submitting without a summary of the edit. So I did.

It seems like in the mean time, jesup made an edit, and then my edit squashed his.

This shouldn't happen, I suspect? Does wiki.mozilla.org have any simultaneous edit warnings? A quick experiment suggests not...

Gerv
There is definitely a midair collision mechanism in MediaWiki, as I've seen it.

Maybe there's a bug? (Maybe it's been fixed in later versions of MediaWiki?)
I tested this recently after someone made a similar report as Gerv. I saw the edit conflict notice, it looks like this:
https://www.flickr.com/photos/subfictional/17180430701/in/dateposted-public/

I have not been able to reproduce an edit conflict situation that does not give this warning. If anyone has exact steps to reproduce, that would be helpful. Perhaps it has something to do with the lack of edit summary warning?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1155839
You need to log in before you can comment on or make changes to this bug.