Conversation name vanishes if the window is detached by dragging

VERIFIED FIXED in Firefox 43

Status

Hello (Loop)
Client
P4
normal
Rank:
41
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: adalucinet, Assigned: standard8)

Tracking

unspecified
mozilla43
Points:
2
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox43 verified)

Details

(Whiteboard: [conversatio] [bug])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Reproducible on 39.0b1 build 2 (Build ID: 20150523155636)
Affected platforms: Windows 7 64-bit, Mac OS X 10.9.5, Ubuntu 14.04 64-bit

Steps to reproduce:
1. Start a call.
2. Detach conversation by dragging the window.

Expected result:
Conversation name is displayed.

Actual result:
Conversation name is not displayed.

Notes:
1. Screencast: https://goo.gl/7KZQMx
2. Browser console output when detaching: 'TypeError: win.gBrowser is null' thrown by ReaderParent.jsm:168:0

Updated

2 years ago
Rank: 41
Flags: firefox-backlog+
Priority: -- → P4
Whiteboard: [conversatio] [bug]
(Assignee)

Comment 1

2 years ago
Created attachment 8659800 [details] [diff] [review]
Loop conversation name vanishes if the window is detached by dragging. Don't try to set the title in the wrong place - let the detachChatbox code set the title.

I took a quick look at this and it turns out that the drag specific detach code is trying to set the title, but hasn't got the right title. Additionally, the detachChatbox code already has embedded within the facility for setting the title on detach.

So I think all we need to do is to remove the broken part of the code.
Attachment #8659800 - Flags: review?(mixedpuppy)
(Assignee)

Updated

2 years ago
Assignee: nobody → standard8
Attachment #8659800 - Flags: review?(mixedpuppy) → review+
(Assignee)

Updated

2 years ago
Iteration: --- → 43.3 - Sep 21
Points: --- → 2

Comment 2

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/0c7ecbc66443
https://hg.mozilla.org/mozilla-central/rev/0c7ecbc66443
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Flags: qe-verify+
(Reporter)

Comment 4

2 years ago
Verified fixed with latest 43.0a1 (from 2015-09-15), across platforms [1].

[1] Windows 7 64-bit, Mac OS X 10.9.5 and Ubuntu 12.04 32-bit.
Status: RESOLVED → VERIFIED
status-firefox43: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.