Loop server accepts bogus room IDs

RESOLVED DUPLICATE of bug 1110937

Status

Hello (Loop)
Server
RESOLVED DUPLICATE of bug 1110937
3 years ago
3 years ago

People

(Reporter: ekr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8613050 [details]
Screen Shot 2015-05-29 at 12.51.37 PM.png

If you put in a bogus room ID, the loop server just acts like it's a real ID and shows you the waiting in room UX.
(Reporter)

Comment 1

3 years ago
Created attachment 8613054 [details]
Screen Shot 2015-05-29 at 12.55.27 PM.png

And then when you try to start the call it fails and offers to let you "Retry" as if that's going to help

Comment 2

3 years ago
More to the point, there's no check for token validity prior to granting camera access. What we're going to want to do here is a GET for the room information prior to acquiring the camera, and issuing an error message before asking the user to join the conversation.

I'll note that the current error message you get in this case (after granting device access) is accompanied by a "retry" button. This button should be removed, since retrying an invalid room token is never going to work.
This is bug 1110937 - we need to move the GET to before the join. Originally the server didn't allow a GET before the join, but that was changed and we haven't caught up yet.

That bug is also going to drop the retry button.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1110937
You need to log in before you can comment on or make changes to this bug.